Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
philmywallet
Creator
Creator

List Box Jumps to Top

Hi

I have a list box with many items.  It has check boxes for multiple selections. I have reduced it's size so it has a scroll bar.  The list is sorted by alphabet, and not by state.

Every time I scroll down and select an additional selection the list jumps back up to the top of the list (or first selection), so I have so scroll back to where I was in the list make make my next selection.

Is there a way that I can make sure the selection stays on the last one I have I have made?

Thanks

Phil

8 Replies
Chanty4u
Champion III
Champion III

hi,

dere is advanced search..with in that u can give the value last where u hve selected and clik on goadva.png

sunny_talwar

When you are making your selection are you pressing Ctrl while making a selection? If you are not then you can use Ctrl to make multiple selection and pressing Ctrl ensures that you are not sent to the top after the selection is made

vsudhakar
Creator III
Creator III

THERE IS A ADVANCE SEARCH GO THAT OPTION AND GIVE THE VALUE AND SELECT THE GO BUTON

philmywallet
Creator
Creator
Author

I thought about the CTRL option, and this does work, but not ideal for the front end user.  The advanced search option would probably take longer to type the last search, than it would to scroll down, so that's not going to work.

I am looking for a way that the list box doesn't change position when making a selection?

Regards

Phil

jagan
Luminary Alumni
Luminary Alumni

Hi,

Hold Ctrl button and select the list of items you wish to select.

Regards,

jagan.

avinashelite

try like this : Go to chart properties > Sort tab> un-check the sorting on state option

sunny_talwar

Try unchecking Sort by 'State' on the Sort tab:

Capture.PNG

Not applicable

Hi,

Make sure that in the Properties under Sort section, State is not checked.

Regards,

Snehal Nabar