Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

List Box Re-sort on Select/De-Select

Hello, All!  Anyone ever notice that when you make a selection or de-select a value in a List Box, the available values re-sort themselves?  Has anyone figured out a way to make the sort order of the available values static, such that the values do not dynamically sort when you make a selection, but always remain in the same order?    

1 Solution

Accepted Solutions
Not applicable
Author

Thanks for the responses, all.  Unchecking Sort by State does not solve the problem.  I don't want my list of values to re-sort at all when I select/de-select a value. 

To solve this problem, we've used the following Expression for the Sort:

=Minstring({1}FieldToSortBy)

View solution in original post

4 Replies
pover
Luminary Alumni
Luminary Alumni

Are you describing the sort on state  (ie. selected values or possible values appear first and not possible values appear last) that QV does?  If so, you can disable this in the sort tab disabling the option to sort on "State".

Karl

CELAMBARASAN
Partner
Partner

Hi,

     Un check the State option in the Sort tab of the Chart Properties.

     Chart Properties-->Sort-->Uncheck the Sort by State option.

Celambarasan

Not applicable
Author

Thanks for the responses, all.  Unchecking Sort by State does not solve the problem.  I don't want my list of values to re-sort at all when I select/de-select a value. 

To solve this problem, we've used the following Expression for the Sort:

=Minstring({1}FieldToSortBy)

View solution in original post

luciancostin
Contributor III
Contributor III

Thank God, I also didn't know how to fix this, since unchecking 'sort by state' also had no effect on my side.

I also had tried sort by expression = FieldToSortBy, but that also didn't help.

Your solution works perfectly!