Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
sifatnabil
Specialist
Specialist

New Salesforce TLS requirements

Hi all,

We have to all soon migrate to the TLS 1.1 protocol, meaning we have to update the QV Salesforce connector. I just installed the v14 connector and retried our Salesforce dataload, and getting this error on the Task object:

Capture.PNG

Does anyone know how to get the new Salesforce connector working? I'm assuming it meets the TLS 1.1 protocol. I tried both BULK and SOAP modes of connection and getting the same error.

1 Reply
smac_panw
Contributor II
Contributor II

Hi Sifat,

Are you able to make the SFDC connector works?  Just change the SELECT_ALL to SELECT.

I have an issue when using the latest SFDC connector version 14.1.  When I retrieve the data from CaseHistory table with the where clause (Where field = 'Owner'), it gives me an error below

"Unable to get column information for the fields that are used in the query. Please make sure you have only one SELECT statement in a query editor. Description: Relationship queries with polymorphic key (keywords TYPEOF, Owner, Who and What) are not supported by the connector."

Wondering if you encounter the issue and have a solution.


Thanks,

Stewart