Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
nancy_sbeity
Partner - Contributor III
Partner - Contributor III

On Open Reload in QlikView

Hello,

My Target is to reload my qlikview application On open.

I am using QlikView server. I have created a run macro script on open from the document settings. My code:

Sub ReloadOnOpen

     ActiveDocument.Reload

End Sub

Then I have added this document to my source documents on the server, so each user will be able to access it from its own QlikView desktop. But the problem is that the reload code didnt work at the level of the user and even at the level of the server.

I tried all the suggestions on Community.  Can anyone provide me with the right answer?

Thank you in advance

Best Regards,

Nancy Sbeity

 

 

Labels (3)
25 Replies
nancy_sbeity
Partner - Contributor III
Partner - Contributor III
Author

Please find attached. I dont know what is missing.

pradosh_thakur
Master II
Master II

It should work. Ask the user to ctrl+M and manually run the macro. Let's see if it works or not.
Learning never stops.
nancy_sbeity
Partner - Contributor III
Partner - Contributor III
Author

Hello,

 

Nothing happened when I clicked on ctrl+M!

pradosh_thakur
Master II
Master II

ask the user to open the macro manually and run it. See if that works.
Learning never stops.
nancy_sbeity
Partner - Contributor III
Partner - Contributor III
Author

Hello,

 

User doesn't have the access to open the macro manually. Document properties is disabled. How can I allow the user to access the macro?

pradosh_thakur
Master II
Master II

nancy_sbeity
Partner - Contributor III
Partner - Contributor III
Author

No good news!

Is it because of the user have Qlikview12?

I have applied every single thing.

pradosh_thakur
Master II
Master II

no.. macro works on qlikview 12. You may need to check your user preference and document settings. reload it as an admin . make sure the macro override security are checked .
Learning never stops.
nancy_sbeity
Partner - Contributor III
Partner - Contributor III
Author

Document Settings: Macro override security is checked.

User preferences: Confirm Launch from Macro is checked.

Macros two checkboxes on the server also checked.

What else?

And thx for your continuous support Smiley Happy

pradosh_thakur
Master II
Master II

It should work. Let me tag @marcus_sommer . He might know why this is happening and help you out.

Learning never stops.