Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On Demand Webinar: See Why Thousands of QlikView Users Have Switched to Qlik Sense. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
momofiore
Creator
Creator

OpenStreetMap Deosn't load any more - QlikView

Hello Community,

Is there any update on OpenStreetMap ultimately?

I have an application QlikView with an openStreetMaps in base maps and it deosn't load any more. 

attached screenshut for the application before and now:

Before:

-There were city names,Valleys, sea and other things on the application (see pict please)

Now:

-There is no more those things like before.

any body has ideas?

thanks.

 

 

Labels (5)
1 Solution

Accepted Solutions
momofiore
Creator
Creator

Hello Guys,

I contacted the GeoQlik about the issue, they said that all the GeoQlik Version under 12.1 can not connect to openStreetMap, so they provided 2 solutions:

-Upgrade the GeoQlik Version.

- Add a new link to a Map on GeoQlik: 

on geoqlik management console -> Manage your maps -> Map services -> Add à map service, add new base map using l'URL  http://a.tile.openstreetmap.org/{z}/{x}/{y}.png

I tried the second solutions and it works perfectly.

So thank you Guys for your support.

Regards

View solution in original post

4 Replies
Brett_Bleess
Support (Former)
Support (Former)

Really need further information in order to offer up anything, but I would have to imagine something has changed on the OpenStreetMap side of things, so I would probably have a look around their site to see if they posted any changes to things there that might explain the behavior and suggestion on how to address it.  

The only thing I could suggest from our side would be to have a look at the GeoAnalytics product:

https://www.qlik.com/us/products/qlik-analytics-platform

That may be a much better option for you potentially.    Here is OpenStreetMap forum link for you:

https://forum.openstreetmap.org/

The only thing of which I can think is something changed in the request/response such that you are no longer getting the names etc., but not sure why that would be, but I would expect it is something on the OpenStreetMap side.  If you get further information, leave an update, and I can see if I can get something further then, but at the moment, I think asking on that side is the better place to start in this case.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
JonnyPoole
Employee
Employee

i agree with that too.  Could you share the QVW ?  Or an example URL of the background image (slippymap) where the qlik variables are resolved ?

momofiore
Creator
Creator

Hello Guys.

Well in few words I had the openStreetMap working perfectly then I lost it few months ago. GeoQlik Can't connect to OSM any more. I had contact with GeoQlik Support and they said that i have an old version that deosn't support OSM any more.

Here is a screanshut for the openstreetmap on my GCSM.

Thank you all

momofiore
Creator
Creator

Hello Guys,

I contacted the GeoQlik about the issue, they said that all the GeoQlik Version under 12.1 can not connect to openStreetMap, so they provided 2 solutions:

-Upgrade the GeoQlik Version.

- Add a new link to a Map on GeoQlik: 

on geoqlik management console -> Manage your maps -> Map services -> Add à map service, add new base map using l'URL  http://a.tile.openstreetmap.org/{z}/{x}/{y}.png

I tried the second solutions and it works perfectly.

So thank you Guys for your support.

Regards

View solution in original post