Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
rudywelvaert
Creator
Creator

Pivot table bold dimension only when value on top row

Hi,

I'm using a chart of pivot table type.

One of the dimensions is pivoted.

I want the values of that dimensions in bold, so I use the expression ='<b>' in the Text Format of that dimension.

Strangely enough the value of that dimension is only bold if the expression is not missing on the first row of the other dimension

When the the expression value is missing, then the dimension value is not bold.

To illustrate this I added a qvw file Bold_Dimensions.qvw.

I have a table with 3 colums: NAME, YEAR, NUMBER

I created a chart of pivot table type with the dimensions NAME and YEAR and the expression =Sum(NUMBER)

The dimension YEAR is pivoted and it's values have to be bold so I used the expression  ='<b>' in the Text Format


When the expression value is missing on the first row then the YEAR is not bold


bold_not_bold.png

To indicate this is no coincident I added a second table to order the 5 names in 5 different orders in such a way that every name comes first in one of the orders

And in 5 identical charts I add onde of the order fields as a the dimension and use it as sort field

You can clearly see that the rule stands: missing value of the expression on the first row: not bold, not missing value of the expression: bold

Is there a way without changing the data to make the values of the pivoted dimension always bold whether the expression value is missing or not on the first row

Thanks

1 Solution

Accepted Solutions
devarasu07
Master II
Master II

Hi,

Try to use Design grid (short cut key CTRL+G) mode instead of  '<b>'

once you have enabled design grid mode then right click over the Year dimension value and right properties then go & click on

"custom format cell" and enable bold check box that's it. for more refer to the attachment.

Capture.JPG

close your thread by marking as correct. thanks

Regards,

Deva

View solution in original post

3 Replies
devarasu07
Master II
Master II

Hi,

Try to use Design grid (short cut key CTRL+G) mode instead of  '<b>'

once you have enabled design grid mode then right click over the Year dimension value and right properties then go & click on

"custom format cell" and enable bold check box that's it. for more refer to the attachment.

Capture.JPG

close your thread by marking as correct. thanks

Regards,

Deva

View solution in original post

rudywelvaert
Creator
Creator
Author

Deva,

thanks for your reply.

This works perfectly

R.

Marcos_Ferreira_dos_Santos

Thank you guys! Deva, your answer helped me a lot today.