Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
arnoqlik
Contributor II
Contributor II

Please enter your User ID while using NTNAME in the Section Access

Hello,

I read several threads about section access but none helped me.

I'm connected on the Qlikview server with an Admin account. I'm part of qlik_admin user group in the Active Directory.

The application I'm working on loads a security.qvs script to set the different levels of authorizations. As for the Admin acccess, here is the code:

SECTION Access;
AuthorizationTable:
// user who needs to have admin access
LOAD * INLINE [
    	ACCESS, NTNAME, %AUTHID
    	ADMIN, qlik_admin, '*'
];

 

As soon as I save this code and reload the application I get this message: 

user_identification.png

 

The only solution I found to be able to reopen the application is to open it from the desktop version of Qlikview 12 on my laptop (instead of the server), comment the loading of security.qvs and run the application from the QMC...

I already discussed with the Admin of the Qlikview server and my access seem to be OK in AD.

What else could explain my issue?

Thank you very much!

8 Replies
Chanty4u
Champion III
Champion III

Hi Can you try this

LOAD ACCESS,  UPPER(NTNAME) as NTNAME, %AUTHID 

inline[

ACCESS, NTNAME, %AUTHID
ADMIN, qlik_admin, '*'
];

Section Application;

 

arnoqlik
Contributor II
Contributor II

Thanks but it doesn't help.

Chanty4u
Champion III
Champion III

try same script  by removing single quotes in star 

 

LOAD ACCESS,  UPPER(NTNAME) as NTNAME, %AUTHID 

inline[

ACCESS, NTNAME, %AUTHID
ADMIN, qlik_admin, *
];

Section Application;

 

Do this also:

Under Settings - Document Settings - Opening:

 

Check the checkbox named : Initial data reduction based on Section Access

Reload the document, save and close the instance completely and reopen.

arnoqlik
Contributor II
Contributor II

The option was already enabled in the document properties.

I still have the popup.

Chanty4u
Champion III
Champion III

is ur Admin is correct name?  like it should come with "domain\Name "   give a try 

 

LOAD ACCESS,  UPPER(NTNAME) as NTNAME, %AUTHID 

inline[

ACCESS, NTNAME, %AUTHID
ADMIN, Domain\qlik_admin, *
];

Section Application;

 

arnoqlik
Contributor II
Contributor II

Do you mean "Domain" as the name of the server on which I'm connected to?

Actually the person in charge the application before me didn't have any issue (with the same security script). Is there another setting within QMC or the document properties of the application where we could define authorizations?

arnoqlik
Contributor II
Contributor II

Sorry but I don't see how it can help me.

I tried this code:

SECTION Access;
AuthorizationTable:
// user who needs to have admin access
LOAD * INLINE [
    	ACCESS, NTNAME, %AUTHID
    	ADMIN, qlik_admin, '*'
    	ADMIN, <my_admin_account>, '*'
];

I can open the document now but I have no access to the data...