Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
jmehallow
Contributor II
Contributor II

QVD File Size in QV11

We recently upgraded from QV9 to QV11.  The code I used in QV9 to create QVD files still works but the files are MUCH larger.  When I "browse" the contents of the QVD files, the QV 11 files are storing more precision on numeric values and they are storing dates differently than before. 

The behavior is the same with the desktop QV refresh and also with the Management Console.  Is there a new setting that I missed? 

My QVWs that are creating these QVDs have "high" compression on them, but I do not think that makes a difference when creating QVDs.

1 Solution

Accepted Solutions
jmehallow
Contributor II
Contributor II

I worked with Qlikview support to resolve this issue.  As it turns out, the problem is a known bug in the system that was first introduced in QV 10R4 and carried into QV11 IR.  To resolve the issue in Qlikview developer and to understand more about it, see the attachment. 

To resolve the issue on the QV Server, follow these instructions:

Shutdown the QV services on the server.

Go to:  C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch\Settings.ini

Before the statement “CurrentQVConnect64Loc” add the “AllowDataLineage=-1” ( make sure this has the upper and lower letter cases)

Restart the QV services

View solution in original post

5 Replies
rbecher
MVP & Luminary
MVP & Luminary

Hi,

this is very interesting. You haven't changed anything like the connection or database provider?

For instance: there is an issue with Oracle OLEDB connect on 64-bit:

community.qlik.com/message/169946

Can you post some example QVD files for a research?

- Ralf

Vizlib Head of R&D
jmehallow
Contributor II
Contributor II

Your post on the Oracle OLEDB issue on 64-bit may be part of the problem.  I need to look into that some more.  It's strange that I did not have that behavior in QV9 though.  I am on 64-bit and I am using Oracle OLEDB.

I haven't changed anything in the environment or in the QVWs.  All I did was complete the upgrade to QV11.  I believe I had to uninstall QV9 to get the QV11 installer to run.

When you asked for QVD files I started looking for something I could share publicly that I also had created in QV9 before we upgraded.  When I generated the same file using QV11, it wasn't any larger.  It still has the date fields stored the same as the other QV11 files but it didn't produce the dramatic file size difference that I am seeing with other reloads.  These differences I am talking about produce QV11 files that are 22MB when the exact same data in QV9 was 177KB

This is an example of the content difference in the QVD files.  The "DT" field is a date that is read from an Oracle DB.  This is the result from the QV11 refresh.

QV11_browse.bmp

Here is what the QV9 file looks like for the exact same result set from the Oracle query.  Notice the DT column.  I am using QV11 to "browse" both of these QVD files:

QV9_browse.bmp

rbecher
MVP & Luminary
MVP & Luminary

What the both pictures show is the same numerical value for the timestamp. In the first case somehow it is not interpreted as a date/timestamp. Maybe this is a different problem but I doubt that this is the cause for the different size.

I know there is a change in the meta data description for the data types in the XML header of the QVD file between QV10 (or earlier) and QV 11. You can just take a look into with an editor.

But, this huge difference in size could only came from different amount of records, I would presume...

Vizlib Head of R&D
jmehallow
Contributor II
Contributor II

I worked with Qlikview support to resolve this issue.  As it turns out, the problem is a known bug in the system that was first introduced in QV 10R4 and carried into QV11 IR.  To resolve the issue in Qlikview developer and to understand more about it, see the attachment. 

To resolve the issue on the QV Server, follow these instructions:

Shutdown the QV services on the server.

Go to:  C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch\Settings.ini

Before the statement “CurrentQVConnect64Loc” add the “AllowDataLineage=-1” ( make sure this has the upper and lower letter cases)

Restart the QV services

View solution in original post

Not applicable

Is there any workaround  for this bug?