Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
See why Qlik was recognized for the seventh year in a row – and discover how we can help you tackle your data integration challenges. Get the report
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QVX_UNEXPECTED _END_OF _DATA

I have created a view in Oracle database which is working fine in Oracle. It is huge and it contains 2 million+ rows. I have  indexed one column. But I am getting QVX_UNEXPECTED _END_OF _DATA error when I do a simple sql select to load it in the qvd.

error.PNG


I read it some where to use ErrorCode = 0 in the query and I did that it got the error "File has wrong format" which in the imageerror code.PNG


There are many columns in the view which are create based on calculations and It shows some file format error but

I checked one by one column  to see if there some format error happening but qlikview returns all the rows when I apply where clause. I believe this problem of large dataset but however it has returned around 1M rows before. I dont know what is the exact problem.

I have also attached the screen shots. Please comment !! Thank you

Note: Testing is same as SCG_PROCESS_FLOWS_BACK_END_VW

1 Solution

Accepted Solutions
Not applicable
Author

It worked after I changed a value of column in the view. Before the column originally was (column * 1  ) after that I removed multiplication by 1 and now it is working fine. Strange !!

View solution in original post

4 Replies
vishsaggi
Champion III
Champion III

Read this post if it gives any help:

QVX_UNEXPECTED_END_OF_DATA

ziadm
Specialist
Specialist

I think this error is thrown by the ODBC driver.  May be you are using function that are not able to be translated by the ODBC.  Size is not an issue

try to use field name instead of select * and see which field are throwing the error

Not applicable
Author

It worked after I changed a value of column in the view. Before the column originally was (column * 1  ) after that I removed multiplication by 1 and now it is working fine. Strange !!

ziadm
Specialist
Specialist

please mark correct and close the thread