Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QVX_UNEXPECTED_END_OF_DATA

What is QVX_UNEXPECTED_END_OF_DATA? One of our Client is facing this problem, when they load data from Oracle.Please find the Snap Shots Attached

Thanks

Rupam

44 Replies
stonecold111
Creator III
Creator III

Go to log file and check after which table you are getting this error. and copy and paste this connection string at the start of that table.

then whenever it timed out. we have one more connection.

danilodalosse
Partner
Partner

The script has just one table.

stonecold111
Creator III
Creator III

Can you tell me the number of records you are fetching from database??

If it is so big, then u need to Create 2 or 3 small QVD's.(using where condition)    Not a single QVD

Then it will work

danilodalosse
Partner
Partner

It isn't so big! Around 2 million records.

But I'll try to create small QVD's.

ellyodelly
Creator
Creator

Just wanted to pop in because so many believe it is the size-  it is not-  when my issue was occurring I was loading at most 2500 records.  In our case it would run fine at 9 and fail at 9:15 and run again fine at 930.

So it is not the amount of data.

maksim_senin
Partner
Partner

Hi All,

There are really several reasons hidden by the error, it our case it also occurs due to problems with connectivity with DB server or other sources (e.g. Active Directory or Web).

So personally I got the error in the following cases:

1. data size

2. connectivity problems


Best regards,

Maxim

Shady_Ayesh
Contributor
Contributor

Hi all,

 

In my case, I solved this issue by changing the query timeout in my connection.

Since, the default value of query timeout is 30 and if you have huge data you have to increase this value according to your data volume.

 

I wish this will help you.

Best regards

Margaret
Creator II
Creator II

I got this error on some SQL in QlikView. When I pasted it into SSMS I got "invalid parameter used in left() or substring() function"

Hannah94
Contributor III
Contributor III

Old Thread but I had the same issue today. Maybe it helps someone:

In my case it was because of bad data in the connected data base. I searched in the affected table and found a row with asian symbols. It's data that got filled in today before the error occured. Couldn't solve the Problem so far (because I couldn't delete or edit it) but this is the trigger for sure.

kevinpintokpa
Creator II
Creator II

@Hannah94 , did you find a workaround for your bad data?  I have the same problem, but am not sure how to get rid of the bad data.