Skip to main content
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
Showing results for 
Search instead for 
Did you mean: 
Not applicable


What is QVX_UNEXPECTED_END_OF_DATA? One of our Client is facing this problem, when they load data from Oracle.Please find the Snap Shots Attached



45 Replies
Not applicable


I have the excacly same situation. Does anyone know what to do?

The problem is that it has been working ok for few weeks and now all of the sudden we receive this error!!!

Please help,

Not applicable


It looks like i have found the solution:

In my case i was accessing the same (quite large) table subsequetly. (i was extracting table to qvd's and then dropping table after reloading it)

It took a few seconds to store it to qvd and it looks like that sql or. qv needs some time before "re-accessing" the same large table in sql.


1 reload of the large table

2. reloading few other tables

3. and then agian reloading the same table.

In my case it works ok now.

P.S. It is funny thougn because this problem appeared all of the sudden (it was working fine for a month but now i got this error)


Creator III
Creator III

This has happend to me as well.

Accessing a quite large table at the end of the load script (6 million records)saving it to qvd and dropping it gave me the above error.

The solution was simpler then you have suggested, I moved the table to the start of the loading script, at the end of the list I have a lot of small tables.

That fixed the problem.

I hope it will help some one.



Not applicable

I'm getting this      QVX_UNEXPECTED_END_OF_DATA error now loading a file from Oracle. I'm not saving it to qvd, just a simple load. It only has 365k records. It has been loading fine for quite some time, and now within the last few days I'm getting this error. Does anyone have any ideas or suggestions for the fix?

Not applicable

Has anybody found a solution to this problem? I am having the same error with a data load from Oracle?

Not applicable

We are facing the same problem, though with DB2:

QVX_UNEXPECTED_END_OF_DATA: ErrorSource: IBM OLE DB Provider for DB2, ErrorMsg:  CLI0108E  Communication link failure. SQLSTATE=40003

Strangly it worked for some time, and then stopped. The table we are loading are not that big ~ 780 KB....

Are there any suggestions?

Not applicable

I had the same error.

After reinstalling the transports to the SAP System (check all options: Import again, Overwrite objects in unconfirmed repairs, Overwrite originals), the error vanished.

It maybe that after an upgrade, not all objects are overwritten.

Not applicable

I encountered this error while loading a SQL Function, the resulting table was not so large (+/- 23.000 records) but still QV did not seem to pul it of.

Any ideas on making the reload of a function more efficient?

Partner - Specialist
Partner - Specialist

Hello all...

I got the same error extracting data (about 500k records):

01/04/2013 2:13:34 AM: QVX_UNEXPECTED_END_OF_DATA:

01/04/2013 2:13:34 AM:       Error: OLEDB read failed

Connecting to a Oracle database via OLEDB...

The most weird thing is that if I run the script from Qlikview Desktop, there is not problem at all... but from QVS, the task fails with the mentioned error...

I have QVS v 11.2 and Oracle 11g

Any ideas, please?