Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView forum consolidation is complete. Labels are now required. LEARN ABOUT LABELS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QlikView Charts do not load after saving and opening

This behavior just started.  I created a new dashboard, made some changes, and everything was working well and quickly.  I saved the workbook, and when I opened it again, I get some grayed-out charts with the hourglass that never goes away.  If I reload the data, everything is again fine.  Just to make it more interesting, the last two times I have tried this, different graphs were gray and the others were working.  Task Manager doesn't show any activity from QlikView.  It is only this one qvw that is giving me trouble.  The file works fine in AccessPoint.

I hope that you haven't seen this before, but if you have, could you please tell me what you did to fix it? 

9 Replies
Not applicable

I'm hoping that someone has seen this behavior before.  It is getting very difficult to develop this any further if I have to reload every time.

Can a qvw get corrupted?  If so, can that be fixed?  I have a lot invested in this dashboard - would starting over be something to try? 

Not applicable

I just recreated the document.  The behavior is exhibited in the new document, as well.

The only thing I am doing in this document that I haven't before is making containers of containers.  I have a container of charts, that is in a container. The inside container has three or four charts, and the user selects which chart by using the 'Dropdown at top' in the container.  The charts inside the container are the ones that are grayed out and get the hourglass.

Has anyone used this approach - a container of charts?  I really need to find an answer to this!

Not applicable

Hey Blair,

This usually happens if your local desktop has less RAM. As you mentioned this doesn't happen in Access Point I think thats the cause.

Usually for development you dont need the entire data set. Try using a limited data set.

Not applicable

I haven't tried that before - it just limits the data until you reload again?  I'll give it a try and post the results.

Thanks

Not applicable

Limiting the data is not working.  I haven't tried no data, as I still need to at least see the charts.  Very frustrating.

Not applicable

Did you do a limited load in Data-Model. Like 10,000 rows. You shouldn't do it in Front-end qvw. I suppose your Front-end qvw is a binary load of the Data-Model qvw.

So please try limiting in Data-Model and let me know how it went.

Thanks

AJ

Not applicable

I have tried removing all the data, and I still get the Hourglass over the listbox for changing to another chart in my container.  So I cannot make changes to the dashboard, as I can't even get to the objects I want to edit.  I will try reloading again.  I have never had a problem like this with dashboards much larger than this one.  That is why I think it might have something to do with the container of container issue.

Not applicable

I made a copy of the document and removed the containers.  I can see that some of the charts do take longer than others to load, but they do load within a few seconds.  It appears to me, in this particular instance, that the containers hamper the loading of the document making it very difficult to work on.  Confusing and frustrating, as the containers are really essential to make the interface look what had already been designed.  I know it's backwards, but that is what I inherited.  If I find anything else out I will post.

Not applicable

OK - now this is just weird, although it may be a work around.  My document was displaying the same hourglass behavior: I couldn't switch graphs using the selector.  I was just messing around while I waited, and switched to WebView.  And suddenly everything worked!  And when I switched back, it still worked.  Weird, but at least I can make changes again.