Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
ankitaag
Partner - Creator III
Partner - Creator III

QlikView: Document Availability settings in QMC

Hi All,

I have mounted 10 Application folders in QMC having 20+ docs in each one of them, out of which only 3-4 to be shown in Access Point. Currently all my 200+apps are being shown in AccessPoint which I do not want. I know that by changing the Availability settings in User Documents for each app will work (Ref screenshot attached). But since, I have 200+ docs I do not want to do it manually, so is there any way to change this setting in any config or setting file to avoid manual work?

 

clipboard_image_0.png

Thanks and Regards,

Ankita

Labels (1)
1 Solution

Accepted Solutions
ankitaag
Partner - Creator III
Partner - Creator III
Author

Ok, so removing domain user groups or local groups doesn't help, but Denying permissions did.

Now what am I doing is, moving all the non browsable apps in a sub folder inside browsable folder and denying all the permissions from the Domain user group, this way those apps are not visible on Access Point. 🙂

You saved my lot of time. I really appreciate your kindness and patience.

Thankyou so much for resolving this. Have a good day!

 

Regards,

Ankita

View solution in original post

14 Replies
Brett_Bleess
Employee
Employee

I would venture the easier way to accomplish things in this case is to use NTFS permissions on the files to 'hide' them from the users.  Had you done your folder structure differently, you could have used the 'Browsable' check box in the QVS settings in the QMC to restrict things, but since you have browsable and non-browsable in the same folder, the only 'easy' solution of which I know is to use NTFS to only allow the service account access to those you want the users not to see and leave those that they should see set to the Local Users etc. such that they will see those...  Need further use case details if this is not what you are looking for.  

When you use the Documents\User Documents area to change things, those settings are generally stored to the associated .meta files, and those are not editable.  If you do things in Documents\Source Documents, those are going to be part of the QVPR file information, which will be pushed to the QVServer using a QVServer distribution, you did not say whether or not you have Publisher license, if so, there may be a way to edit the QVPR file(s) to do this, but things may or may update on the QVS side of things as some settings only push on the initial run of the task and the QDS App Data may need to be cleared and recreated with a full push from the QMS service to populate everything such that the distributions will be updated properly.  

This is likely a bit confusing, but this is a fairly complex topic to try to explain in the Community post, but hopefully this helps explain things a little.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
ankitaag
Partner - Creator III
Partner - Creator III
Author

Thankyou so much for your reply.

I do not have publisher license so no access to Source Documents section. However I tried to change one of the QVPR html file and tried to give the default property of the check boxes to 0, but didn't work -- as you said "as some settings only push on the initial run of the task and the QDS App Data may need to be cleared and recreated with a full push from the QMS service to populate everything such that the distributions will be updated properly.  " 

I think either I opt to do it manually -- which is next to impossible ( I have more than 500 apps, 200+ was an idea) or I try to change my folder structure (Create separate folders for non browsable ones) and the reload jobs (if required).

 

Regards,

Ankita

Brett_Bleess
Employee
Employee

Yeah, so you are reloading the apps in place, the apps the QVS is using, the only way you have to configure things would be NTFS rights restricting the ones you do not want users to see or changing your folder structure such that you can mark the ones you do not want visible not browsable.  Here are a couple of Help links as well:

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/QMC/Content/QV_QMC/QMC_System_Setup_QlikVi...

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/QMC/Content/QV_QMC/QMC_System_Setup_QlikVi...

I believe the easiest fix for you would be to leave the files that have tasks on them, the ones you do not want the users to see as they are and move just the ones you want them to be able to see to new folders, but that could break the tasks on those, just FYI, been a while since I did Reload Engine setup etc.  Actually, the easiest thing is likely the NTFS rights, as that should do the trick quite nicely, just remove the 'users' from the files you do not want them to see and that should hide things in the AccessPoint page, that is likely the easiest solution for you and should not be too much work hopefully, might be able to write a PowerShell script to do that for you potentially...  Sorry I do not have anything better for you.

Just be sure the Qlik service account maintains Full Control over the files you are trying to hide from the users, as without that, your reloads will likely fail...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
ankitaag
Partner - Creator III
Partner - Creator III
Author

If I understood maintaining NTFS rights -- it is manually adding user names in folder's security option. If yes, then again not possible, but if no then please guide me through.

Otherwise, the only left option now I see is to move the non browsable apps in new folders and uncheck the browsable option, this way my tasks remains intact.

Thanks and Regards,

Ankita

Brett_Bleess
Employee
Employee

If you simply remove the local users security group from the apps you do not want users to see, that should do the trick...  As long as the QV service account is a local Admin, it should still have full rights via the Administrators local security group.  Not sure if it would be faster to change folder level and push down to files and then reset the files the users need to see, I think that would be given you said there were only 3 apps per folder that needed to be visible...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
ankitaag
Partner - Creator III
Partner - Creator III
Author

It's not working, I removed local user group and Domain user groups in one of the app's security but it is still showing on Access Point (Logged in with a user account and not admin account). Only admin accounts have access to now

 
 
 
Brett_Bleess
Employee
Employee

If you changed things on the folder do not forget you have to push that change down to the files in the folder...  Believe there is a checkbox on the Advanced settings to do that, but I suspect that is what you missed here...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
ankitaag
Partner - Creator III
Partner - Creator III
Author

I did not not do this change in the entire folder but to an app inside it (to check the working).

Steps followed:

App Right click -- Properties -- Security tab -- Advanced button -- Permissions tab -- Selected Domain Users -- Click edit -- uncheck "Include inheritable permissions from the object's parent" -- ok -- Remove -- apply

 

Regards,

Ankita

Brett_Bleess
Employee
Employee

Are you running QVServer in NTFS or DMS security mode?  QMC\System\Setup\QVS resource\Security tab settings...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.