Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
ankitaag
Partner - Creator III
Partner - Creator III

QlikView: Document Availability settings in QMC

Hi All,

I have mounted 10 Application folders in QMC having 20+ docs in each one of them, out of which only 3-4 to be shown in Access Point. Currently all my 200+apps are being shown in AccessPoint which I do not want. I know that by changing the Availability settings in User Documents for each app will work (Ref screenshot attached). But since, I have 200+ docs I do not want to do it manually, so is there any way to change this setting in any config or setting file to avoid manual work?

 

clipboard_image_0.png

Thanks and Regards,

Ankita

Labels (1)
14 Replies
ankitaag
Partner - Creator III
Partner - Creator III
Author

NTFS

PS: Thankyou so much for your quick responses and time.

Brett_Bleess
Employee
Employee

Ok, so given NTFS, that means QVS is relying upon Windows to determine Authorization, something has to be wrong in the changes you made, can you do the Effective Permissions in the Advanced area and put in the username to be sure it reports back they have no access?  

Found a nice site that has a lot of screenshots etc. that should help here, but that is the best way to confirm what you actually have, as I think something is still granting access here.

https://www.thewindowsclub.com/effective-permissions-tool-windows

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
ankitaag
Partner - Creator III
Partner - Creator III
Author

Ok, so removing domain user groups or local groups doesn't help, but Denying permissions did.

Now what am I doing is, moving all the non browsable apps in a sub folder inside browsable folder and denying all the permissions from the Domain user group, this way those apps are not visible on Access Point. 🙂

You saved my lot of time. I really appreciate your kindness and patience.

Thankyou so much for resolving this. Have a good day!

 

Regards,

Ankita

terrykavouras
Contributor II
Contributor II

Hey Brett,

I found this topic in Community and I have a similar issue I'd like your help with.  I have a number of docs that are used by NPrinting, but I don't want them visible to users.  All the apps use Section Access.  This is important because I can't put the documents in a non-browsable folder because NPrinting accesses the qvw using the user's credentials.  So if the doc is in a non-browsable folder, NPrinting will fail because it can't find the document.  I thought I had found a solution by clearing the Access Method options, that is, clearing the IE Client and the Full Browser and Small Device Version check boxes (User Documents > Server > Availablity > Access Method).  This works except when I reload the qvw the Access Method options get reset - they are both checked, that is, they are both enabled.  This seems like a bug to me, by the way; why allow me to alter the Access Method if it's going to be reset after a reload.  Anyway, I need a solution.  If I can set the Access Method and have it stay cleared (unchecked) that would work.  Otherwise I need another solution if you know of one.  

p.s. How the heck are you?  I really miss you and my other QlikPals.  Hope you're doing well.  

terrykavouras
Contributor II
Contributor II

Forget my last email.  I just found the Availability option in the Source Documents task definition.  I'm an idiot.  Anyway, I think I know what to do now.