Skip to main content
Product Release Webinar: Qlik Insider airing December 6! REGISTER TODAY!
Showing results for 
Search instead for 
Did you mean: 

QlikView and SQL's ListAgg() function

Hi QlikView and SQL Experts -

Does anybody have experienced an issue with creating a new field using ListAgg() function in SQL Select statement? I am getting this error when I try to run with ListAgg()


Error: OLEDB read failed

What I am looking to do is very simply. Lets say I have the following data

Key     Dim     Sales

1     India     50

2     India     100

3     India     20

4     US     30    

5     US     60

6     US     120

I want this from SQL (and not QlikView)

Key     Dim     Sales

1|2|3     India     170

4|5|6     US     210

SQL Query runs without any error in SQL Developer, but errors out in QlikView when I use ListAgg() function to create 1|2|3

Looking for some advice here gentleman

pcammaert‌, gwassenaar‌‌, swuehl‌‌, johnw‌, marcowedel‌, jagan‌, rubenmarin

33 Replies

Hi, maxgro said he tested a simple listAgg and worked, he was using a 32bit oracle client and I remember in a customer they didn't wanted to install the 64 bits driver because they detected issues (I don't know wich issues)... have you tried to force the 32 bit driver?


I have not, let me try this as well.


Unfortunately, I won't be able to test this out anymore. So, this thread will be unfinished business I guess