Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
LanBiteam
Partner
Partner

QlikView client opens too slow

Hello,

Our customer has met a problem, that the QlikView Decktop is taking too long to open(about 8-10 minutes).

It has nothing to do with specific QVW yet, since only opening the client is taking forever.

But we noticed that if we open the client as administrator, then the performance is better. So I think it is not Windows environment problem. 

The other user which meets problem, has also full access to QlikView and the Apps. There is no problem opening anything from Access Point.

I don't understand the reason now. Please help.

(The QlikView version is November 2017 SR9)

Best Regards,

Lan Cao

Labels (3)
1 Solution

Accepted Solutions
marcus_sommer
MVP & Luminary
MVP & Luminary

A direct re-installation of the desktop client didn't touch the settings.ini. Even without any problems you may do it 3 - 4 times in a year to update to the newest release and because of the fact that the settings.ini isn't changed you don't need to set all user-properties again and again. Beside this there could be here and there some registry-settings - most of the settings are within the settings.ini but a few may not especially some settings from older releases which may also not changed/deleted through a re-installation.

Therefore I wouldn't be surprised if there are anywhere references to this not available path maybe set within the user-properties to the various path-settings of buffer, themes and so on. After a quick search to the error-messages it seems bit more likely for me that this issue is mainly caused from Windows and it's mechanism to use more or less hard-coded favourite-folders for desktop, downloads, documents and so on and that any customization from the users went wrong.

You may think the last shouldn't be related to QlikView but QlikView used nearly overall it is possible the Windows default features/libraries/paths during the installation and while running the tool. 

- Marcus

View solution in original post

8 Replies
RogerG
Contributor III
Contributor III

Sometimes there are ghost QVW apps running in windows.  check the task manager to make sure there are none.  other than than that, I don't know much.

 

marcus_sommer
MVP & Luminary
MVP & Luminary

I assume most of the time nothing happened on the CPU or RAM else QlikView is just waiting for anything. Maybe waiting for connecting to the licence server or initialising any path-settings if they are set to network-shares or similar things. Also possible that there is any open popup-window from QlikView asking for any action which is behind other windows or outside of your screen (AFAIK in this case QlikView waits forever but maybe there is anything which has a timeout and used afterwards some default-settings).

At first I would backup and then remove the settings.ini from the user and trying then the opening again.

- Marcus

LanBiteam
Partner
Partner
Author

Thanks a lot for the hint. We have checked the Task Manager but it doesn't show other QVW tasks running. 

LanBiteam
Partner
Partner
Author

Hi Marcus,

Thanks a lot for the advise. Removing the Settings.ini didn't help us on the case. 

But we have found one error in Windows Event (Event ID 502):

"Failed to apply policy and redirect folder "Documents" to "\\Domain\Folder example" .

Redirection options=0x1001.

The following error occured: "Failed to build the list of regular subbirectories under "\\domain\Folder example""

Error details: "The netword name cannot be found." "

 

Now we assume that there is access issue with this user to the domain folder. We need to wait for the IT Admin to check on this.

But we are not sure if this has caused the Desktop issue with opening. Please share if you will have any thought about this error. 

Best Regards,

Lan 

 

marcus_sommer
MVP & Luminary
MVP & Luminary

I think this is the reason of the long opening times from QlikView because resolving network addresses have often timeouts of a few minutes. To the underlying cause you will probably need your IT to repair wrong settings or to approve the proper access rights.

- Marcus 

LanBiteam
Partner
Partner
Author

Hi Marcus,

I agree with your opinion. I am still wondering, why is QlikView checking for the non-relevant folder path when opening the client. Maybe there is old settings in history about this path. But I even had re-installed QlikViewDesktop. Shouldn't this history been reset after new installation? If you know if I can delete this  manaully? (The settings.ini from the user's folder was re-generated after new installation.)

Thanks a lot!

Best Regards,

Lan

marcus_sommer
MVP & Luminary
MVP & Luminary

A direct re-installation of the desktop client didn't touch the settings.ini. Even without any problems you may do it 3 - 4 times in a year to update to the newest release and because of the fact that the settings.ini isn't changed you don't need to set all user-properties again and again. Beside this there could be here and there some registry-settings - most of the settings are within the settings.ini but a few may not especially some settings from older releases which may also not changed/deleted through a re-installation.

Therefore I wouldn't be surprised if there are anywhere references to this not available path maybe set within the user-properties to the various path-settings of buffer, themes and so on. After a quick search to the error-messages it seems bit more likely for me that this issue is mainly caused from Windows and it's mechanism to use more or less hard-coded favourite-folders for desktop, downloads, documents and so on and that any customization from the users went wrong.

You may think the last shouldn't be related to QlikView but QlikView used nearly overall it is possible the Windows default features/libraries/paths during the installation and while running the tool. 

- Marcus

View solution in original post

LanBiteam
Partner
Partner
Author

Understood. Thanks a lor for the clarification about settings.ini. 

Best Regards,

Lan