Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
maxloveiii
Contributor III
Contributor III

Qlikview 12.20 stop calculation, How to fix?

Hi Qlik experts,

        My Qlikview app is Variance dashboard.It's using comparative by alternate state with a lot of amount of million rows(20M) and app very large size. Although it slow calculation but still working until charts finish calculation but after upgrade to Qlikview ver. 12.20 and now 12.30 my app stop calculation progress bar has green colour but CPU stop process with very low % and app show not responding  and I'm not sure that what change or fix bug in version 12.10 to 12.20 and 12.30 because of I still can run on version 12.10.  I unfortunately did not work on new version.

 I apologise for my bad English.

messageImage_1543402334165.jpgmessageImage_1543402382056.jpg

Max

3 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

Did you check the datamodel within the tableviewer? Maybe something goes wrong within the script-load and now some associations are broken and  the UI tries to calculate anything with unconnected fields.

- Marcus

maxloveiii
Contributor III
Contributor III
Author

Thanks for reply quickly Marcus,
My datamodel just 1 fact table(Actual,Budget concatenate model) and 1 calendar table and when I roll back to Qlikview ver 12.10 my app work properly. I think the problem is version of Qlikview but I don't know how to setting for new version because by customer was upgrade to new version already.
Thanks for your help.
marcus_sommer
MVP & Luminary
MVP & Luminary

Of course there might be any bug in the newer releases in regard to your used measures but before I would search for similar occurences or reporting a bug I would check my measures if any change to the used settings and/or announced bug-fixes or new features could cause the issue.

Changed settings could be for example different format-variables and if I remember correctly there was a change to the quotes-usage within set analysis - single quotes around strings will be now not more valid for a search-string else only double-quotes, whereby there are also additionally options if the old or new treatment should be applied - and changes like this might lead to failures within your expressions and might cause this endless calculations.

Therefore I would go into these objects and disabling nearly all dimensions/expressions and then enabling them again step by step and so you will see what caused these performance-issues and if you then compares it against the one from the previous release you should see any differences and the real cause will be visible. In regard to this it might be useful to open the application without the data and then to load only a reduced dataset per debugger.

- Marcus