Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
test_it_1234
Contributor III
Contributor III

Qlikview 12 dynamic background image

Hi all,

i am using Google Map in my Application. It works fine in Qlikview 11.

Today i got Qlikview 12. Now i have a issue with dynamic background image in charts.

The google API Call working correct in browser but not as background image in charts.

Back to qlikview 11 all is fine

Is there a known Issue or any changes ?

Thanks

Frank

16 Replies
isaiah82
Creator III
Creator III

I am in the process of upgrading to QV12 (the latest currently available ~ 12.1 SR7) and experiencing the same issue with Dynamic Image backgrounds not working.

Has anyone found a workaround for this?

isaiah82
Creator III
Creator III

I found the following article on the support portal that addresses this: https://qliksupport.force.com/QS_CaseWizardKnowledgeArticle?id=kA5D00000004N7oKAE&_ga=2.47275751.171...

test_it_1234
Contributor III
Contributor III
Author

I cant open the link, i have no salesforce access.

Have they found a solutiuon ? My solution is downgrade to Qlikview 11.

isaiah82
Creator III
Creator III

Nothing yet ~ if you have a support contract I would recommend opening up a case and reference bug ID: QV-11063 (the more folks who report this give it more weight to get fixed more quickly.)

Here's a snippet from the article; not sure I completely follow, but support should be able to provide more guidance.  If I read this correctly, the underlying issue is that QV12 is forcing to attempt authenticating to the HTTP proxy, even if the proxy is not configured for authentication, but I might be wrong about this.

Workaround until the bug fix:
Proxy has to be configured in order to authenticate all communication for the url that is used
for example http://maps.googleapis.com/maps/api/*
so if it's possible, at proxy level, white-list all requests for the domain that is used.

 

View solution in original post

mataylesbury
Contributor II
Contributor II

Hi, Does anyone know if this is fixed in 12.2? I can't find anything in the release notes that suggests so...?

Thanks.

isaiah82
Creator III
Creator III

Mathew > I believe this is fixed, but I needed to tweak the settings.ini file.  According to the following article (you'll need to be logged into the support portal for the link to work): List of Bug Fixes included in QlikView November 2017 (12.20) this was fixed in the 12.20 initial release.  But just upgrading didn't do the trick.

Check out this article for the solution:  Dynamic images (from URL eg Google Maps) are not visible in Qlikview 12.10 if a proxy is used

Specifically:

add in Settings.ini the following configuration WebFileUseWinAPI = 1

Best -Isaiah

mataylesbury
Contributor II
Contributor II

Thanks Isaiah, i'll try this once we've upgraded to 12.20.