Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
Sean_BI
Creator
Creator

Qlikview EDX - AllowExecuteCommand

Dear QV team -

Struggling to get this worked.

QV installed in Win 2016 with two node clustered. Enterprise edition QV v12 is configured.

I have installed the qv server in d:\ in both nodes where node 1 have all the 5 qv services and node2 have only qv services running.

Edx is also running in d:\ in node1. 

I am unable to view setting.ini file located in C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch

to add an entry "AllowExecuteCommand"=1 value.

The service id and log in id are member of local win admin group. I've also created Qlikview EDX and added service and log in id as members.

I've been referring to various links in this community, but do not have step by step procedure.

https://community.qlik.com/t5/QlikView-Scripting/AllowExecuteCommand-setting-violation-detected/m-p/...

Kindly assist.

Rgds,

Sean.

2 Solutions

Accepted Solutions
Albert_Candelario

Hi Sean,

the settings.ini on C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch is located on the node where you have the Distribution service installed.

Could you double check?

Thanks

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

Albert_Candelario

Hey,

Glad we solved. Please, do not hesitate to use the Community to share with all of us anything regarding the Qlik products.

Enjoy Qlik!

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

3 Replies
Albert_Candelario

Hi Sean,

the settings.ini on C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch is located on the node where you have the Distribution service installed.

Could you double check?

Thanks

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

Albert_Candelario

Hey,

Glad we solved. Please, do not hesitate to use the Community to share with all of us anything regarding the Qlik products.

Enjoy Qlik!

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

Sean_BI
Creator
Creator
Author

Dear Albert -

Can you please assist on EDX a bit..

I've the EDX installed on windows 2016 server and is located in

D:\QVEDX\QMSEDX_CommandLine\QMSEDX

D:\QVEDX\QMSEDX_CommandLine\QMSEDX.exe

I've added the below entry as well.

C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch\setting.ini

[Settings 7]

AllowExecuteCommand=1

I've also added the service id in the local group policies

Computer Configuration>Windows settings>Security setting>Local policies > User Rights Assignments>Log on as a service> 

Computer Configuration>Windows settings>Security setting>Local policies > User Rights Assignments>Log on as a Batch Job> 

Issue1:

I've the automation qv script scheduled in QMC which is scheduled every 15 min for reloading extractors. 

This automation qv script calls the command line QMSEDX.exe. This work fine. But the other extractors are not getting trigged which are on Edx mode. (refer to attachment)

Can you please assit.

Rgds,

Sean