Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Qlikview Google BigQuery Connector not working

Hi all.  Thanks in advance. I am attempting to connect Qlikview to Google BigQuery using the BigQueryConnector provided by Qlikview.  I am able to paste the Google ClientID and ClientSecret into qlikview and press Authorize.  That brings me to the google Auth page in browser.  I press Accept and then Qlikview gives me an error saying the Client Secret was not validated. see below. Apparently the OAuth2.0 Authentication page did recieve the verification code but Qlikview produces this error so I can't enter the code into the connect string.  We have tried resetting the google ClientID and Secret and have insured that google is set up correctly.  I'm convinced that the authentication dance is getting interrupted some how by qlikview.  Can anyone please help?  Has anyone successfully written a custom javaScript connector to perform the dance and query data?  Or any other ideas?

NotAllowed.PNG

9 Replies
Not applicable
Author

Hi Anthony,

where can i download the connector?

I'm not able to find it in the QV Website.

Thanks,

Lorenzo.

m-wise
Partner
Partner

Hi Anthony,

Did you get this working? I've got the same error message on our server.

When I try the same thing on my laptop all works fine.

I'm out of ideas what could be the difference between the two installations.

Roy

Not applicable
Author

Hi Roy, We did not find a solution.  The connector works on our server but not on my laptop.  We figured it was our companies firewall settings for laptops.  I would suggest looking into your firewall settings for your server.  Good luck.

m-wise
Partner
Partner

Hi Anthony, Finally found the problem. It only took me 3 days .

I had to install .NET 4.5, after that it worked like a charm.

So the error handling of Qlikview failed again...

Not applicable
Author

I am having this same issue, already have .NET 4.5 installed. I click allow and then it fails. The BigQuery options seem to have changed since this post:

How to set up Google BigQuery access with Direct Discovery

Has anyone found a solution?

Not applicable
Author

Hi Brian.  Installing .NET 4.5 worked for me.  Did you get the same error as the original post?

Not applicable
Author

Yes it is the exact same situation, however I have .NET 4.5 installed already.

Not applicable
Author

If you still have this issue after installing .NET 4.5 it may be your proxy.

- Install a clean version of the connector.

- Open the folder: C:\Program Files (x86)\Common Files\QlikTech\Custom Data\QvBigQueryConnector

- Add the following code in the <configuration> tag in the QvBigQueryConnector.exe.config file:

<system.net>

<defaultProxy useDefaultCredentials="true" >

</defaultProxy>

</system.net>

jayaprakash_qv
Contributor
Contributor

Hi

Did you find any resolution for this ? Please let me know