Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
May 18th 10AM ET, Live Chat, bring your QlikView questions. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
rupaliqlik
Creator
Creator

Qlikview PDF can not generated from Access Point through Button

Hi Folks,

I have designed the pdf with the help of Qlikview Report Editor.Also set all the properties in button .And manually generated the pdf which is successfully generated .when I try to print the report from access point it gives 'Timeout has been exceeded'.Please help me how can I generate via access point.

 

Thanks,

RuE

 

Labels (1)
1 Solution

Accepted Solutions
Brett_Bleess
Support (Former)
Support (Former)

Rupali, have a look at the following Article reference, it may not look like the issue, but if the report takes a bit to generate, this should be at least part of the problem here:

Ajax client request timeout setting 

The default is 60 seconds, so if you know how long the report takes to generate, set that timeout to that value plus a buffer, hopefully that will do the trick for you.  If this does not work, shout back, and I can to think of what else may be in play.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

7 Replies
Brett_Bleess
Support (Former)
Support (Former)

Rupali, have a look at the following Article reference, it may not look like the issue, but if the report takes a bit to generate, this should be at least part of the problem here:

Ajax client request timeout setting 

The default is 60 seconds, so if you know how long the report takes to generate, set that timeout to that value plus a buffer, hopefully that will do the trick for you.  If this does not work, shout back, and I can to think of what else may be in play.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

stig1984
Creator II
Creator II

Hi,

I am experiencing the same issue and was looking to follow your solution,

However the link is not active - would you be able to confirm it.

Thanks,

Brett_Bleess
Support (Former)
Support (Former)

Stig, I refreshed things in my other post, let me know if it still does not work, it seemed to be working for me, so it should be good now, not sure what happened there, sorry about that.  If it does work, let me know, so I can mark my other post as the solution at that point.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
stig1984
Creator II
Creator II

Spot on,

thanks,

stig1984
Creator II
Creator II

Thanks for you help on this - your solution combined with re-installing the print driver resolved all the issues.

Thanks,

martinzalloccodxc
Contributor II
Contributor II

I experience the same issue too. So, I would like to know where to set up the timeout, which is the print driver you reinstalled (name, version, etc) and where do I need to install it (qlikview publisher, qlikview server, distribution server). Thank you in advance!

stig1984
Creator II
Creator II

The link in @Brett_Bleess  post above is valid for changing the timeout.

The printer re-installed was on the qlik server and was the standard PDF Xchange normally installed with Qlik - I think this was particular to my circumstance so would try the time-out setting first.  If needed though the details can be found on the Qlik help site around deploying Qlik