Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Qlikview desktop not saving Macro security settings

Hello,

I've read and tried some of the articles regarding the Qlikview desktop application (12) not saving users' Macro Security settings but having no luck in finding a solution.

One user always has to press Control Shift M to allow Macros to execute as Qlikview doesn't seem to change save the setting. This works, but she then has to change this every time she goes back into Qlikview. She's using it via the program rather than in IE with the QV plugin.

I've tried looking in :

C:\Users\<username>\AppData\Roaming\QlikTech\QlikView


...but unlike other users (even users logging into the same machine), no "settings.ini" has been created. An "initial.ini" is there though. I've tried placing another users' "settings.ini" in there but Qlikview doesn't seem to take those settings.


This user has now tried on two machines, with fresh installs of Qlikview but each have the same issue. I've looked through the registry on the machine but can't see anything relating to this setting (I've read that this setting was remove from the registry from the latest version of Qlikview in any case).


Any help or suggestions are much appreciated.


Regards,


Steve

1 Reply
jonathandienst
Partner - Champion III
Partner - Champion III

Its a long time since QV used the registry - I think the last version was 9 (plus or minus). If no settings.ini file is being created its possible there's a security problem or a lock on that machine which is making the user's AppData folder or sub-folder(s) read only for the user. I think a failed write to settings.ini will fail silently and the file will not be updated

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein