Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
LINKEDIN LIVE: Democratizing data to enhance customer-centricity. JULY 29TH REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
onkarkulkarni
Creator
Creator

Reference data not getting loaded untill I reload

Hello all,

 

I am working on the straight table where in I am showing Country and sales. Requirement is to show 20 countries every time.

e.g.   Even if I receive sales data for 5 countries, I need to show '0' sales for rest 15 countries.

 

For that I am loading Country’s reference data table having 20 countries along with actual data sheet. So that in table there always will be 20 countries.

 

Now the issue is - when I am opening my dashboard it is showing only those countries present in actual data. Post reload it is showing all the 20 Countries. Not getting why reference data is not getting loaded at first instance only.

 

Hope I am clear with my requirements.

 

6 Replies
ahaahaaha
Master
Master

Hi,

Try to remove the flag1.jpg

arvind_patil
Partner
Partner

Hi Onkar,

could you provide sample app.

Thanks,

Arvind patil

onkarkulkarni
Creator
Creator
Author

This is already removed.

stabben23
Master
Master

Hi Onkar,

try to tick "Show all Values" in dimensiontab, then untick "Suppress Zero-Values" in presentation tab.

onkarkulkarni
Creator
Creator
Author

Tried that as well. Actually I noticed that section access code is impacting entire application. If I comment that it is working fine

stabben23
Master
Master

Ok, so sequrity comes in second hand?! Better GUI is Perfect? You gambling to high I think.