Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
dhirajkumar
Creator
Creator

Same Formating of qlikview pivot table in Excel

Hi Everyone,

Here in qlikview I want to send a pivot table in Excel but in excel its not showing the same formatting  as in qlikview .

I'm attaching image and qvw file . Please anyone give me some solution that  we can fixed the Issue.

8 Replies
ashfaq_haseeb
Champion III
Champion III

Hi,

I cannot access the file its corrupted.

But below macro will do the job.

  1. sub Export
  2.     set XLApp = CreateObject("Excel.Application") ' Define Object 
  3.         XLApp.Visible = True 'Visible set as true 
  4.         set XLDoc = XLApp.Workbooks.Add 'Open new workbook     
  5.         set table = ActiveDocument.GetSheetObject("TB04") 
  6.         rem set table = ActiveDocument.GetSheetObject("MB01") 
  7.         
  8.     set XLSheet = XLDoc.Worksheets(1) 'Select sheet where data should be pasted 
  9.         table.CopyTableToClipboard true 'Copy data to Clipboard
  10.         XLSheet.Paste XLSheet.Range("A1") 'Paste data into cell
  11.     
  12. end sub

Change the object ID's accordingly.

Regards

ASHFAQ

dhirajkumar
Creator
Creator
Author

Hi Ashfaq,

Thanks for the reply but here I'm not able to run this code . when we put the object id of pivot table in  place of TB04 then what we should put the id object in place of MB01.

ashfaq_haseeb
Champion III
Champion III

Hi

Please have a look at the attached application

Also make sure you give system access to Macro in module as per the attached image.

Hope it helps

Regards

ASHFAQ

dhirajkumar
Creator
Creator
Author

Thank you so much ashfaq now its working...

ashfaq_haseeb
Champion III
Champion III

Hi,

If it works, Please close the thread by selecting appropriate answer.

Regards

ASHFAQ

Athira_K
Contributor III
Contributor III

Hello,
This is working fine for my requirement also.Can you please help me with saving the file?
Thank you

Butterfield
Contributor III
Contributor III

Right-click a cell in the pivot table, and click PivotTable Options. On the Layout & Format tab, in the Format options, remove the check mark from Autofit Column Widths On Update. Add a check mark to Preserve Cell Formatting on Update. Click OK.

 

My Kohls Charge

Athira_K
Contributor III
Contributor III

Thank you for helping me out.