Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
andreyfcdk91
Creator
Creator

Second axes in line chart

Dear Colleagues, good day!


I have line chart with 2 expr. Is there any way to add second axes for second expr?


Example in attachment.



Many thanks.


1 Solution

Accepted Solutions
Gysbert_Wassenaar

You can choose to put the second expression on the secondary axis on the Axes tab. It's a bad idea because you'll create a confusing chart. It's better to use two charts for this. Can you tell which expression belongs on which axis if you only look at the chart?

comm191934.png


talk is cheap, supply exceeds demand

View solution in original post

8 Replies
Gysbert_Wassenaar

You can choose to put the second expression on the secondary axis on the Axes tab. It's a bad idea because you'll create a confusing chart. It's better to use two charts for this. Can you tell which expression belongs on which axis if you only look at the chart?

comm191934.png


talk is cheap, supply exceeds demand

View solution in original post

mark6505
Partner
Partner

Hi,

I would have to agree with Gysbert, I would approach as two charts.

In the Axes tab highlight the expression > Tick split axes.

Mark

andreyfcdk91
Creator
Creator
Author

No, i can't tell at once dependence between expr and axes.

Now i'm trying to show second axes and it's display isn't practical.

Could you advice something for it please?

balrajahlawat
Champion
Champion

This is happening becoz of -ve values in expression..

Could you post sample data for same?

balrajahlawat
Champion
Champion

will this help you?

see the attachment..

Gysbert_Wassenaar

My advice is to use two separate line charts.


talk is cheap, supply exceeds demand
vincent_ardiet
Creator III
Creator III

Hi,

Uncheck the "Forced 0" option it will look nicer.

anna_castan
Contributor II
Contributor II

Thankss!!! 🙂