Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
jmvilaplanap
Specialist
Specialist

Section Access doesn't works properly

Hi All,

I have a document with Section Access, when I upload the document to the server it works fine, but when the document is reloaded by the server, the restrictions disappear and every body can see the whole document. What's happening? Anybody can help me?

(I'm using NTName for the section access)

Thanks a lot.

1 Solution

Accepted Solutions
jmvilaplanap
Specialist
Specialist
Author

Sorry guys,

I found the error, the transform stage in the server was not in the last version and one necessary field for the Section Access was not in the data model, it's because was working when I uploaded the app from my pc and not when was refreshed on the server.

Thanks a lot to everybody

View solution in original post

7 Replies
jubarros
Luminary Alumni
Luminary Alumni

Hi Jose Miguel:

Is the user whos execute de task included in the section access?

Best Regards,

Juan P. Barroso

jmvilaplanap
Specialist
Specialist
Author

Yes, the server reloads the document without problem, the problem is that the document loses the Section Access and the whole document is available for every body.

tresesco
MVP
MVP

The qv server uses service account to reload the application. Are are sure the same service account is part of your section access and has admin privilege? Also, are using inline section access code or from some external file? If you are using external file to include section access, you have to check it's access right as well so that the same could be read by service account.

jmvilaplanap
Specialist
Specialist
Author

If the problem was the service account, Qlik couldn't open and reload the app, and it can do it. The problem is that the section access disappears and the document works as a regular document.

MindaugasBacius
Partner
Partner

Are those ticks on in Document Properties?

Screenshot_2.jpg

jmvilaplanap
Specialist
Specialist
Author

Yes, all works perfectly if I reload the app on local and I upload it to the server, but when the app is reloaded by the server, it lost the Section Access.

jmvilaplanap
Specialist
Specialist
Author

Sorry guys,

I found the error, the transform stage in the server was not in the last version and one necessary field for the Section Access was not in the data model, it's because was working when I uploaded the app from my pc and not when was refreshed on the server.

Thanks a lot to everybody

View solution in original post