Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Section Access for one special field

Hello Community,

how can i build the Section Access Script, that 2 of 3 Users, can see the content of a field/listbox in the application

So User A and B should see the content of the listbox "test" in the Application but User C is not allowed to see the content. So the listbox should have no values.

Thanks for any help!

Best regards,

Aylin

3 Replies
jagan
Luminary Alumni
Luminary Alumni

Hi,

Try the OMIT option in Section Access, check below example

Example 5:

Section Access;

LOAD * INLINE [

ACCESS, USERID, PASSWORD, OMIT

ADMIN, ADMIN, ADMIN,

USER, USER1, U1, SALES

USER, USER2, U2, WAREHOUSE

USER, USER3, U3, EMPLOYEES

USER, USER4, U4, SALES

USER, USER4, U4, WAREHOUSE

USER, USER5, U5, *

];

Section Application;

LOAD * INLINE [

SALES, WAREHOUSE, EMPLOYEES, ORDERS

1, 2, 3, 4

];

In this example, the field OMIT has been added as part of Section Access.

USER1 will not be able to see the field SALES, USER2 will not be able to see field

WAREHOUSE and USER3 will not see field EMPLOYEES.

USER4 has been added twice to the solution since we want to OMIT two fields for this

user, SALES and WAREHOUSE.

USER5 has a “*” added which means that all listed fields in OMIT will be unavailable.

USER5 will not be able to see fields SALES, WAREHOUSE and EMPLOYEES.

Hope this helps you.

Regards,

Jagan.

Not applicable
Author

Hi Jagan,

thanks for your help. I tried this, but it doesn't work.

i have already a table in the section access with ACCESS and NTNAME.

Then i make a concatenate with your table :

i take only ACCESS, NTNAME and OMIT.

I dont understand the second table. Does it meansthat SALES with the value 1 will be hidden ?

When yes, i tried this and values like 1 will be shown in my example...

If the value is a string, so i have to use apostrophe 'text'  or not?

Best regards,

Aylin

Not applicable
Author

I solved the problem. in the settings i forgot to check a option