Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Live chat with experts, bring your API Integration questions. June 15th, 10 AM ET. REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
leonard_wei
Partner
Partner

Seeing different Toolbars in Qlikview AJAx/Webview

In Ajax/Webview, there is a toolbar located on top of page where you can find buttons like "Current Selection, Repository". Now the issue here is that there are two different group of user see "Repository" showing as icon in toolbar while the other don't see it as icon but have to click "More" at the end of toolbar.

Anyone knows what Settings are causing this difference, is it on server side or browser side? Advise if you know please, much appreciated!

Both users are accessing the same report hosted on same server with same user group and even same version browser - Chrome

User A:

User A.png

User B:

User B.png

1 Solution

Accepted Solutions
Miguel_Angel_Baeyens

The second one.

However, after a second view, it looks like they are really two different menus. The one from User A looks like it's using the QlikView iOS app or a hybrid device like the Microsoft Surface, which screen can be used also as an input method (tapping or mouse/cursor depending on whether or not it is attached to the keyboard) and the User B menu corresponding to what I can see now in Chrome Desktop (laptop without detachable screen).

In the desktop Ajax client there is no option to "Switch to Small Device Version", the only available is "Full Browser"

It's still a good idea to contact Qlik Support but it looks like they are two different devices.

View solution in original post

6 Replies
fc_375545
Contributor II
Contributor II

It's a bug, we also, I often have different reports on the same report, it does not depend on anything, it's just a bug, which has become a lot lately

leonard_wei
Partner
Partner
Author

Fidel,

I'd agree it's a bug. What's wired is one set of group user are seeing one view, the other set see the other view. I am going to submit a bug report to Qlik Support to see what happens.

Thanks for confirmation.

Miguel_Angel_Baeyens

Just in case, did the users try disabling cache? Use the developer tools in Chrome to remove only cache data for the AccessPoint.

leonard_wei
Partner
Partner
Author

Miguel,

Good point, by removing cache data for AP, do you know which view of menu am I supposed to see correctly?

Miguel_Angel_Baeyens

The second one.

However, after a second view, it looks like they are really two different menus. The one from User A looks like it's using the QlikView iOS app or a hybrid device like the Microsoft Surface, which screen can be used also as an input method (tapping or mouse/cursor depending on whether or not it is attached to the keyboard) and the User B menu corresponding to what I can see now in Chrome Desktop (laptop without detachable screen).

In the desktop Ajax client there is no option to "Switch to Small Device Version", the only available is "Full Browser"

It's still a good idea to contact Qlik Support but it looks like they are two different devices.

View solution in original post

olivierrobin
Specialist III
Specialist III

hello

we have exactly the same case

a user connected on a lenovo PC T480 with touchscreen sees the menu  with repository in "More " option

and if he uses another levoo without touchscreen  T470, he sees the usual menu