Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Our next Qlik Insider session will cover new key capabilities. Join us August 11th REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Show Missing value as 0 in report

Hi,

I create report to show sale cost and in some month don't have sale cost but I need to show value as zero in report when select "Show All Values" for a dimension in Dimension tab report show all value in database include data I don't need to show in report.

16 Replies
puttemans
Specialist
Specialist

How does your variable sale cost look like when there is no cost? a blank, or a '-', or another sign?

avinashelite

simple solution would be , if its a straight or pivot table than go to presentation tab and you will see the representation for the null and missing as - ...change it to 0 it will work ......

if you need it in the script level we have the other ways to achieve it , please let me know if you need that

Not applicable
Author

Hi,

In Presentation tab I set the missing symbol to 0 and null to "-" but in the month that no transaction was not show in report but I need to show it as 0.

Please provide the script.

Thanks.

Not applicable
Author

Hi,

I already set it but it doesn't worked because that month I need to show is no transaction.

If have another way please help.

Thanks.

Kushal_Chawda

1) In Dimension make sure that suppress null values is unchecked for Month.

2) try this expression - Alt(YourExpression,0)

3) In presentation tab uncheck Suppress zero value

Kushal_Chawda

any luck?

ogster1974
Master II
Master II

Sounds like you need a master calendar created in your data load to use as your dimension to link to your fact data.

That way if you miss months in your data you wont have any gaps.

Regards

Andy

qlikviewwizard
Master II
Master II

Hi Use this.

Hope this will helps you.

Capture.JPG

Not applicable
Author

I tried it before it doesn't worked. I think on that point of data is no value in table so then report will not show the result right?