Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
slaheddinekeyru
Partner
Partner

Show only values that accumulate to

Hi community,

I don't know how to describe my problem but it's very simple. I want to transform the straight table bellow into a Pie Chart while showing only values J,I,H,G,F,E that cumulates 80% of the total. My goal is to show biggest values that cumulate 80% of total expression.

You can find example in attachement.

camembert.PNG

Thank you very much for all your answers

1 Solution

Accepted Solutions
sunny_talwar

9 Replies
el_aprendiz111
Specialist
Specialist

Hi,

80.png

slaheddinekeyru
Partner
Partner
Author

Thank you Fer Fer for your answer.

I was affraid that the problem is due to my Qlik Version.

I tried exactly what you did but it doesn't solve my problem.

Can you tell me please what version of QlikView you are using ?

I'm using this one : 12.10.20600.0 SR8

camembert.PNG

el_aprendiz111
Specialist
Specialist

Hi

Version 11.20.12235,0

uacg0009
Partner
Partner

Hi Slaheddine,

I didn't check other threads, but I think Fer Fer's answer is correct, and It maybe a bug for Qlikview 12.

I check it in Qlikview11 and 12.

Show only values that accumulate to1.PNG

Show only values that accumulate to2.PNG

Same setting, different answer.

Thanks.

Aiolos

sunny_talwar

You might be able to try this... but this excludes E because E is greater than 80%...

Sum({<DIM = {"=Aggr(RangeSum(Above(Sum(FACT), 0, RowNo())), (DIM, (=Sum(FACT), DESC)))/Sum(TOTAL FACT) <= 0.80"}>}FACT)

slaheddinekeyru
Partner
Partner
Author

Thank you Aiolos for trying it.

We can confirm it's a bug of Qlik 12.

slaheddinekeyru
Partner
Partner
Author

Thank you Sunny for your Answer,

But this way we can't show the "Others" Values

sunny_talwar

slaheddinekeyru
Partner
Partner
Author

Good shot ! Thanks a lot !

But I think QlikTech must fix this issu