Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
We value your feedback – take our 5-minute QlikView modernization survey
cancel
Showing results for 
Search instead for 
Did you mean: 
danielle_v
Creator
Creator

Straight Table Colours in Report Editor

Hi All,

I have a straight table where the expressions are either red or green based on a text colour expression. However, in report editor only the green is showing - the red results are just showing black (also the dimension/expression labels are showing black rather than white, although this is less important).

Does anyone know how to fix this? I've tried everything I can think of and I've searched on here, but to no avail!Capture 300818.PNG

4 Replies
tush
Creator II
Creator II

Hi,

     Firstly convert the table into pivot table make operation on it by including styles and convert table back to straight table.


for more understanding please go through below link, hopefully will help you:-

http://community.qlik.com/message/217131#217131

Reports and straight table font color

Regards

Tushar

marcus_sommer
MVP & Luminary
MVP & Luminary

I never noticed such behaviour else each kind of formatting like attribute-expressions, custom cell-format or visual-settings do work. Are you sure that you compare the right objects? There might be an earlier copy of it maybe within any (hidden) temp-sheet. To check open the properties of each one and look for the object-id.

If the above wasn't the cause then you could try it by creating a complete new object and/or new report - it's quite rarely but sometimes an object get corrupt.

- Marcus

danielle_v
Creator
Creator
Author

Hi Marcus,

Thanks for your reply. It's definitely the same object that I'm comparing, and I've even created new objects but to no avail.

I've actually just changed the shade of the red slightly in the expression, and for some reason the new shade of red works - if I change it back to the original shade of red, it turns black again on the report version.

I still have absolutely no idea why it's behaving like this, but the amended shade of red is providing a workaround. All most strange!

marcus_sommer
MVP & Luminary
MVP & Luminary

I could imagine that there are differences between the various features to how many colors they could handle. How was the not working color defined and which worked now?

- Marcus