Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
richard_chilvers
Specialist
Specialist

White space error - XML file format

I am LOADing data from a web file, in XML format.

The script runs perfectly when I run it locally on my PC.

When I save the model to server and run it, I get:

Error: Required white space was missing  On line number: 1. On column number: 55.

I have no idea what this error is telling me, so any advice would be welcome.

4 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

richard_chilvers
Specialist
Specialist
Author

Thanks Marcus

I will take a look in detail, but it seems strange the same model works on my local PC but not the server.

marcus_sommer
MVP & Luminary
MVP & Luminary

Have you the same qv version on server and on the local machine? Further for many things used qv no own functionalities else it used windows system libraries (*.dll) and they could differ to each other.

- Marcus

vupen
Partner
Partner

I know I am replying to a very old post, but I had the same problem.

This is seen when you extract pieces of a large LOB using DBMS_LOB.SUBSTR(DB_XML_FIELD, 4000, 8001) from the database, and joining them in QV to create one field that has the full XML content.

While returning data, Oracle is trimming the leading (and trailing?) white spaces.

To overcome this, I used

Replace(DBMS_LOB.SUBSTR(DB_XML_FIELD, 4000, 8001),' ','|') as XML_Chunk_2 from the database, and then replace '|' with ' ' on QV side.

Hope this helps.