Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
cklimmer
Creator
Creator

filtered straigth table with expressions

Hello,

I stuck currently in a maybe simple question.

I have a straight table with several dimensions and expressions.

When I filter the straight table by a criteria I get only those lines where the expression has a result.

But the whished result is a list which shows all lines, also lines with null values from the expressions.

straigth table.JPG

I tried already to deactivate the settings for "display zero values" within the dimension and presentation tab.

And when I try to use an expression like

count ( {1 < CONTACT = {'visit'}   >} [CONTACT] )

the filter value is completely ignored.

Many thanks in advance for your help and best regards,

Claus

1 Solution

Accepted Solutions
ogautier62
Specialist II
Specialist II

and check too 'display all values'

maybe street, zip, city don't need to be dimension, try as expression

View solution in original post

13 Replies
Anil_Babu_Samineni

Try this?

count ( {< CONTACT = {'visit'}, [ZM PR]=>} CONTACT)

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
sunny_talwar

Null values in which dimension? Can you provide some more details here

cklimmer
Creator
Creator
Author

I want to get also addresses as result where the result of calculated expressions is null.
In that example I expect a line with an address where the #visits 12M = 0.

Using [ZM PR]=  within set analysis leads to the same result like count ( {1...

BR,

Claus

sunny_talwar

Might be easy to see the problem if you are able to share a sample?

cklimmer
Creator
Creator
Author

I can only provide screenshots from the settings...

dimension tab.JPG

presentation tab.JPG

In this test object I have currently only one expression.

Hope this helps?

BR,

Claus

sunny_talwar

Can you create the issue in a mock file? If not, then I am not really sure how to help. I hope loveisfail‌ or somebody else is able to help in that case.

Best,

Sunny

ogautier62
Specialist II
Specialist II

Hi,

all your columns seem to be in dimension; but the only expression

so remove one column as dimension if you can,

or add a column : value = 1 and you hide it

regards

cklimmer
Creator
Creator
Author

I tried already to add an expression like =1 and hided it within the presentation tab.

But the result was the same, the calculated expression suppress the lines with 0 visits.

Can you please explain your thought about to "remove one column from the dimensions"?

ogautier62
Specialist II
Specialist II

and check too 'display all values'

maybe street, zip, city don't need to be dimension, try as expression