Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
aniketsr
Creator
Creator

how to have a vertical line in static reports

Hi All,

 

Iam unable to create a vertical solid line in the static report because the line object is not accepted by the report layout.

i used Repeat('|',14) but i get dotted line but we require solid lines.

any work around or help will be appreciated.

 

Labels (1)
1 Solution

Accepted Solutions
johnca
Specialist
Specialist

What version are you using? On server or Desktop? What object are you using? Have you tried =Repeat('|',14) in a text object and get the same result?

View solution in original post

7 Replies
johnca
Specialist
Specialist

What version are you using? On server or Desktop? What object are you using? Have you tried =Repeat('|',14) in a text object and get the same result?
aniketsr
Creator
Creator
Author

Hi ,

Iam using QV 12 . Yes i tried using repeat function in text box but i get dashed lines . The expectation is to have a solid line. 

 

johnca
Specialist
Specialist

How about: Repeat(chr(151),14)  This create a horizontal line.

Are you looking for a vertical line using pipe? The best I could think of is 

=chr(9474) &chr(10)&
chr(9474) &chr(10)&
chr(9474) &chr(10)&
chr(9474) &chr(10)&
chr(9474) ...

but is hardly dynamic and is broken. Maybe someone else knows of a way to make a vertical line dynamic.

johnca
Specialist
Specialist

And I totally missed this one...DOH!

Why not use a Line/Arrow object?

aniketsr
Creator
Creator
Author

Line object cannot be dragged in the report designer

johnca
Specialist
Specialist

I'm missing something here.

Do you have the "Allow Move/Size" box on the Layout tab UNchecked? That will stop you from moving it.

Make sure it is checked.

Brett_Bleess
Employee
Employee

Did John's last post regarding the Move/Size option get things working for you with the line arrow objects?  If so, be sure you return to the thread and use the Accept as Solution button on that post to give him credit for the assistance and to let other Community Members know this worked for your use case.  If you still have further questions, leave an update.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.