Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
markodonovan
Specialist
Specialist

.tmp files created but document doesn't save

Hi there,

Has anyone see this problem :

I am trying to save my qlikview document but it doesn't save but everytime I try to save the document I see .tmp files being created in the folder where the file exists.

Also,  I cannot open the tableviewer or reload the document.

The document itself is very simple just an inline table and a simple table created using autogenerate.

Other documents work fine.  So I might just be a case of recreating the document from scratch.

Thanks

Mark

http://www.markodonovan.com

9 Replies
Not applicable

Hi Mark,

Just asking as to whether this was ever resolved because I am currently having the same issue.

Any help om the matter would be greatly appreciated!!!

Thanks ,


James

markodonovan
Specialist
Specialist
Author

Hi James,

I think I tried things liked rebooting my machine and updating to the latest version of qlikview desktop.

I'll let you know if I remember anything else.

Mark

http://techstuffybooks.com

marcus_sommer
MVP & Luminary
MVP & Luminary

Try it with Save as (F12) and helpful might also be to open a new qvw (maybe in a different instance) and then copy + paste from script and sheets to save your work.

- Marcus

Not applicable

thanks guys,

In the end I had this container that must have been contaminated or something because it was everytime I edited it that my document wouldn't save and now that I completely deleted the container and rebuilt it everything is working again.

Thanks,

James

markodonovan
Specialist
Specialist
Author

Glad to hear to managed to fix the problem.

All the best.

Mark

hugmarcel
Specialist
Specialist

Hi

I recently had the same issue, saving was impossible but .tmp files were created. Changing the restriction mode or saving as... did not help.

What I did was to write a partial load statement at the start of my script. Executing the partial load then allowed me to save the qvw file again.

Marcel

Ronnie_Taborn
Support
Support

It is bug for on certain versions of QlikView.  What version are you on?

hugmarcel
Specialist
Specialist

11.20.12577.0409 SR8

It also seems to me that the problem started when I was starting to work with inputfield functionality...

Marcel

kashyapdhar
Contributor III
Contributor III

Facing similar issue. Random files are generating .tmp files but not saving it into actual qvw file on reload. If i kill the QMC task the .tmp file vanishes, however if i run the same task again it gets saved properly. 

Not able to pinpoint exactly what the issue could be? anyone has any ideas here?