Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for Data Integration and Data Analytics gurus. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Always one selected value on Access point

Hi Guys,

I have one list box containing some values, i have enabled 'Always one selected value' property for that list box. But when i view this application through Access point, then this property of the list box breaks sometimes. It allows people to select more than one value and even clear the selected value when we click on the clear selections button.

Please help me with this.

Thanks in Advance...

5 Replies
Highlighted
Not applicable

Re: Always one selected value on Access point

It´s happening with me too.

Any solution?

Highlighted
Luminary
Luminary

Re: Always one selected value on Access point

I'm dealing with the same issue.

When the file is mounted on Access Point, does it systematically reload new data into the file? I found a theory saying the "Always one selected value" option gets removed if you perform a so-called "Reduce Data operation". The reason for this might be safety so that the file won't get corrupt with fewer data and thus

prevent the file from beeing opened at all. Unfortunately, I haven't been able to replicate this phenomeno, so further information about this topic is highly desired.

Maybe this blogpost describing a workarorund will help you more than it helped me:

http://qlikviewmaven.blogspot.de/2013/01/always-one-selected-value-really.html

Highlighted
Not applicable

Re: Always one selected value on Access point

I am not facing this problem. For me, it works fine on the access point

Highlighted
Specialist
Specialist

Re: Always one selected value on Access point

Hi,

I have checked on my server it works in access point as well.

ok do the following.

1. just delete your listbox and create a new listbox

2. name it in Tite

3. select your selection and then go to properties to check always one selected value.

4. save your application (.qvw)

5. go to your accesspoint and then try to clear all

Let me know if it works this time or not

Regards,

anant

Highlighted
Specialist
Specialist

Re: Always one selected value on Access point

Hi All

I was having this issue between my design copy and the Access point copy too, I found that the instructions in this http://qlikviewmaven.blogspot.de/2013/01/always-one-selected-value-really.html worked but only -

a) when I did it on the server copy not the original (the setting seems to get wiped when deployed to server) and

b) when a selection (and only one) is chosen before accessing the properties box it did not work when no box was ticked.

hope that helps