Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Announcing the newest addition to the Qlik Community, Qlik Gallery! Learn More
Highlighted
pranaview
Contributor II

Background color expressions in the charts are not working for some fields

Hi Guys,

I am not sure what went wrong but suddenly after reloading the document, all the chart's background color expression stopped working and even if i create new charts, background expressions won't work, it only takes the default color theme from settings.

I am very confused about it. Did i mess any setting or something? i don't know what's going on here?

same expressions were working just fine before so it's not about the expressions. But if I use some other fields in the same expression, it seems to work. I'm very puzzled by this.

Please help me with this as this has stopped the deployment process.

 

Regards,
Pranav

1 Solution

Accepted Solutions
pranaview
Contributor II

Re: Background color expressions in the charts are not working for some fields

Hi Marcus,

Thanks for your response and suggestions!

What i found weird was that the same expression was working for some fields and wasn't for some others. Then i went into my script and saw that I had used Purgechar(Trim(Field),'') for those fields. I took the Trim() outside the Purgechar() function the color expression started working. 

Regards,
Pranav 

2 Replies
MVP & Luminary
MVP & Luminary

Re: Background color expressions in the charts are not working for some fields

Your expressions are not be valid anymore and therefore they are ignored. I suggest you creates a new table and use the color-expressions there as normal expressions to see the results which they return. You may need to choose a higher granularity by your dimensions and/or adjust the expression (maybe wrapping them with num() to return the numeric value of a rgb() or something similar) and/or by more complex expressions to split them into several parts. With this work your issue should be obvious - probably some NULL values anywhere.

- Marcus

pranaview
Contributor II

Re: Background color expressions in the charts are not working for some fields

Hi Marcus,

Thanks for your response and suggestions!

What i found weird was that the same expression was working for some fields and wasn't for some others. Then i went into my script and saw that I had used Purgechar(Trim(Field),'') for those fields. I took the Trim() outside the Purgechar() function the color expression started working. 

Regards,
Pranav