Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Not applicable

Bar Offset not working when refreshing dashboard using automated task

Hi,

I have a dashboard where I am using the Bar Offset feature. The data looks good when working on local machine. Charts are populating as expected. I deployed this dashboard to test server and created a 2 tasks - one to refresh te QVD (getting data from tables) and other to refresh the QVW. The moment when QVW is refreshed.... those bars that have Bar offset calculations written start showing 0 as values...

Does anyone know why this is happening? I am using Qlikview 11.

6 Replies
MVP
MVP

Re: Bar Offset not working when refreshing dashboard using automated task

Could you post this QVW?

Not applicable

Re: Bar Offset not working when refreshing dashboard using automated task

Here is the QVW file for your reference.

MVP
MVP

Re: Bar Offset not working when refreshing dashboard using automated task

Do the variables get resetted when you refresh the QVW on the server?

Not applicable

Re: Bar Offset not working when refreshing dashboard using automated task

No, they are static as you could see in variable section.

ahmar811
Contributor III

Re: Bar Offset not working when refreshing dashboard using automated task

hi

sushant pandey

try this link for your reference

Waterfall Chart Offest Using Dimensions

Waterfall chart using dimensions

hope this help you

Thanks & Regards

Ahmar Ansari

Not applicable

Re: Bar Offset not working when refreshing dashboard using automated task

Hi,

Unfortunately this didn't help because of 2 reasons

  • I am not using the dimensions in my charts
  • The issue is that everything is working as expected on local machine. Only when I deploy the QVW on test server and refresh it with help of Task then I am getting 0 as values. Just to clarify, I am using the same data on local machine that I am working with on test server.