Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Emma
New Contributor II

Box plot only showing first value outliers, Urgent Help!

Hi, 

I created a box plot to show the distribution of CycleTimes, but when I change its orientation it only shows the outliers for the first row.

 

The pictures below show the same box plot.

l.PNGCapture.PNG

Upper whisker formula: 

Max(If([Cycle Time]*60<= Aggr(2.5*Fractile(total <Name> [Cycle Time]*60,0.75) -1.5*Fractile(total <Name> [Cycle Time]*60,0.25), Name, [Cycle Time]*60), [Cycle Time]*60))

Lowe Whisker:

Min(If([Cycle Time]*60>= Aggr(2.5*Fractile(total <Name> [Cycle Time]*60,0.25) -1.5*Fractile(total <Name> [Cycle Time]*60,0.75), Name, [Cycle Time]*60), [Cycle Time]*60))

Only using 1 dimension which is Name (the name of the products).

I have been told that it might be a grain mismatch issue but I am not sure how to resolve it here.

Thank you.

4 Replies

Re: Box plot only showing first value outliers, Urgent Help!

You should not have a grain mismatch just for changing the orientation of the chart. Would you be able to share a sample to test this out?

Emma
New Contributor II

Re: Box plot only showing first value outliers, Urgent Help!

Hi Sunny, 

Thank you for your reply, I created a sample for you.

Both Box plots are the same, the only difference is the orientation. Yet, the outliers disappear for all besides the first row once I make it horizontal.

Many thanks.

Amine

Re: Box plot only showing first value outliers, Urgent Help!

This does seem like some kind of a bug. I am seeing the same issue. I think you should reach out to Qlik Support to create a ticket with them.

Emma
New Contributor II

Re: Box plot only showing first value outliers, Urgent Help!

I see, thanks!