Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
richnorris
Contributor II

Button working differently on access point

We have a button that has several actions, most of which are just to clear various fields (this all works) but then the main part of it is to select the last 12 months:

 

= '>=' & Max([12mths]) & '<=' & Date(Max([Max Date]))

 

There's nothing wrong with the logic of this, it works fine locally on the client. When we hoist it up to the access point however it no longer works, and as the selection we instead just get '>=<=' 

I suspect (strongly) it's to do with the date format, as we've had date format issues in the past, which all arose after upgrading to QV12 (Lots and lots of issues actually) that make me think there's some environment variable on the access point that differs from the ones set in the script? Could that be possible? If the format in the dashboard sets it to 'DD-MMM-YY' but on access point it's somehow set to 'DD/MM/YY'? 

1 Reply
Support
Support

Re: Button working differently on access point

One quick test here would be to use multiple buttons to see which part is having issues, try breaking the current single button down into two for starters, the first one doing all your clearing, and the other your selections, that should confirm/deny whether it is one part or the other.  If that works, the best thing I could surmise here is some sort of timing issue going on in the processing of the actions.  That is about the best I have to try to narrow things down a bit more on this one, if you get further details, feel free to post back, but if you get something we should be able to replicate in a virtual environment, feel free to go ahead and open a support case, so we can have a direct look at things to see if we can replicate the issue or not.  Given things are working in Desktop though, and Server is having an issue, most often that means there is most likely some sort of timing issue going on from my experience.  Hopefully this gives you a means to move things forward a bit more.

Regards,
Brett

To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.