Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Not applicable

Chart Labels not Showing up in Qlikview Server

Hello,

I've created an app that works perfectly fine on my local machine but when I upload it to the server the labels on some bar charts are not appearing. I've tried all that I can think to try and still nothing seems to work--can anyone advise? What's mystifying to me is that the mouseover labels are appearing correctly, so it knows the label associated with each bar but for some reason the labels themselves are not appearing. Any help would be much appreciated!

LOCAL MACHINE

local.PNG

SERVER

server.PNG

SERVER W/ MOUSEOVER

server_mouseover.png

Best,

Geoff

1 Reply
Not applicable

Re: Chart Labels not Showing up in Qlikview Server

Hi all,

An update for anyone else experiencing this issue...

My charts have multiple dimensions and I found that if "Show legend" is not checked the dimension ordered first (highest promotion) then any dimension under that dimension will also not have a legend (even if "show legend" is checked on that dimension) in the server environment.

While it is great to see the labels now when I'm in the server environment, I would love for the legend for the first dimension to not appear. Does anyone know how to do this? I've tried to limit its characters but unfortunately can only limit down to 1 and not 0. I've tried changing it's font properties from the "Axes" tab but unfortunately that also changes the properties on the labels that I want to keep. Lastly, I tried changing the text color from the dimension tab using an RGB() expression but this has strangely had no effect (see picture).

textRGB.PNG

Is there anything else that I could try to remove this legend (without unchecking the "Show Legend" box)?

Many thanks,

Geoff