Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Prabhu
New Contributor III

Data from JSON data source is not extracted properly using 'Web Files' option.

Hi All,

I am trying to load data from JSON data source using 'Web Files' option. I get the following script with column name and column value. I want a tabular format with columns and rows. Please do the needful.

LOAD "[{""id"":1",
[DI_SID":"A000060],
["product_id":9],
[provisioned_date":"2018-12-04T00:00:00.000Z],
["last_scan_date":null],
["last_updated":null],
["build_type":null],
["build_version":null],
["serial_number":null],
["inventory_number":null],
[description":"T3],
["host_ip":null],
["manufacturer":null],
["model":null],
["os_name":null],
["os_version":null],
["purpose":null],
["eol_date":null],
[job_desc":"Assoc],
[location":"Avery Rd],
[country":"UNITED STATES],
[region":"AMER],
[city":"Dublin],
[job_type":"Non-Technical],
["createdDateTime":"2019-01-24T06:56:12.000Z"}],

[{"id":8],
[DI_SID":"A000062],
["product_id":1],
[provisioned_date":"2017-01-05T00:00:00.000Z],
["last_scan_date":null],
["last_updated":null],
["build_type":null],
["build_version":null],
["serial_number":null],
["inventory_number":null],
[description":"NULL],
["host_ip":null],
["manufacturer":null],
["model":null],
["os_name":null],
["os_version":null],
["purpose":null],
["eol_date":null],
[job_desc":"VP],
[location":"Tempe Bldg G],
[country":"UNITED STATES],
[region":"AMER],
[city":"Tempe],
[job_type":"Non-Technical],
["createdDateTime":"2019-01-24T06:56:12.000Z"}]

FROM
[https://mtm-api.apps.dev.4a.aia.jse.net/api/vdipaged/0/50]
(txt, codepage is 1252, embedded labels, delimiter is ',', msq);

 

@Gysbert_Wassenaar      @sunny_talwar    @rwunderlich 

1 Reply
MVP & Luminary
MVP & Luminary

Re: Data from JSON data source is not extracted properly using 'Web Files' option.

Try using the REST connector instead of trying to load it as a web file.

talk is cheap, supply exceeds demand