Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Error: safety settings on this computer prohibit accessing a data source on another domain

In a macro I am calling a procedure in the oracle database. In the developper it works correctly, but after deploying and accessing via IE I get the message "safety settings on this computer prohibit accessing a data source on another domain".

I've enabled "access datasources across domains" in the internet options on the client.

In the module editer I've set "allow system access" and "system access".

The macro looks as follows:

sub WriteToDatabase

dim sConn, oConn

    Set oConn = CreateObject("ADODB.Connection")

    sConn = "Provider=OraOLEDB.Oracle.1;Persist Security Info=False;User ID=" & vUserID & ";Password=" & vPassword & ";Data Source=" & vDataSource & ";"

    oConn.Open sConn

    sSQL="procedure_name('" & var1 & "'),'" &  var2 & "')"

   

    oConn.Execute(sSQL)

    oConn.Close

    Set oConn = Nothing

end sub

Note: the called procedure writes in the database.

Any ideas how to prevent this message?

Thanks, Nor.

11 Replies
Highlighted
Contributor III
Contributor III

Hey Nor,

I get the same message from oneof my users.

Have you found a solution?


Best regards

Eran

Highlighted
Not applicable

No, I'm sorry. I've created a very dirty workaround to solve this problem and now I don't use a macro but call the procedure in the script.

Nor

Highlighted
Not applicable

Hi Norarth and Eran,

Sorry for digging this old post up, but I am currently having the same issue.

Did someone find a solution to use a macro ?

Note : the macro is working when I am connected with the server administrator.

Thanks,

Benoit

Highlighted
Contributor III
Contributor III

Hi,

This worked well for me.

Modify the internet options in IE:

Go to Internet options -- Security Tab -- Select Internet and Local Intranet -- click Custom Level (button ) -- Miscellaneous -- select enable for Access data source across domains.

After that I reopened theQLIKVIEW model.

For me it worked..

Good Luck

Eran


Highlighted
Not applicable

Thx Eran for your answer, but this solution didn't work for me.

Strangely it is working for the server administrator.

Has anyone another idea ?

Thx

Highlighted
Employee
Employee

There is a general script setting in QlikView, that will override the Macro  Editor access setting. This setting is commonly set the first time QlikView is  used to run macros, and is set on a user by user basis hence could generate the  different behaviour for different users.

1. Login to Windows with  the user you want to change the access right for
2. Open QlikView desktop  client
3. Open the QVW application
4. Press Ctrl + Shift + M
5.  Change the Macro Module security setting

Highlighted
Creator
Creator

Hi,

I've the same problem...

I access the qvw document by IE pluging how can I set up it to avoid that problem?

Highlighted
Not applicable

Hi Matteo,

You will need to open the application on your server and press Ctrl + Shift + M.

You just need to do that one time.

BR,

Highlighted
Creator
Creator

Thank you,

I’ll try as soon as possible.

I hope that help! ☺

Da: benoit_fr

Inviato: mercoledì 19 settembre 2012 09:58

A: Matteo Fioroni

Oggetto: - Re: Error: safety settings on this computer prohibit accessing a data source on another domain

QlikCommunity<http://community.qlik.com/index.jspa>

Re: Error: safety settings on this computer prohibit accessing a data source on another domain

created by benoit_fr<http://community.qlik.com/people/benoit_fr> in Development (QlikView Desktop) - View the full discussion<http://community.qlik.com/message/260640#260640>