Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi all,

Im getting this error while connecting to Oracle database:

ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

OLEDB CONNECT32 TO [Provider=OraOLEDB.Oracle;Persist Security Info=False;User ID=xxx;Data Source=localhost;Extended Properties=""] (XPassword is xxx)

Oracle server is running and I can connect to it via ORacle SQL Developer...
Can you give me a hand, please?
Im new to qlik

Tags (3)
18 Replies
joshabbott
Contributor III

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Didn't want to start a new thread.  I'm having this exact same problem, does anyone have any idea's?  This works fine on a co-workers machine, but not mine.  I'm not exactly sure where to look.  Thank you for any help!

Not applicable

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi Josh!

You have helped me with all of my questions thus so far.. maybe it's time I can help you! Have you checked to make sure you had the database added in administrative tools?

  • click Start -> Control Panel
  • In Control Panel, double click “Administrative Tools” icon.
  • Then double click “Data Sources(ODBC)” and click “System DSN” tab.
  • It will show “Create New Data Source” window.
  • Choose the Oracle Database and click Finish.
  • Provide the Data Source Name and Service Name, Schema Name and Password.
  • Click Ok to add the data source.

I don't know if that will do it but it's worth a shot... Thanks for all the help you've given me in the past!

Joe

manasamale
New Contributor II

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

I am getting the same error.I checked Data Sources(ODBC),everything is fine and the connection is successful over there.I searched in google but din't find a solution for this..Can anyone please say me whats wrong ...and what can be done to resolve the error..

Thanks in Advance...

Not applicable

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi,

Can you try to connect to the DB using ODBC.create the connections at control panel-> administrative tools->odbc create cnnection der and re use it using qlikview

agomes1971
Valued Contributor

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi,

please check if the provider is correct.

Hope it helps

André Gomes

manasamale
New Contributor II

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

@rakesh goud  I created the connection in control panel ->administrative tools ->odbc and gave the db details in a file and tried calling it using script in qvw..but still i am getting the same error....

Andre Gomes  I checked, the provider is correct..the same details are working fine in my friends system..unable to understand whats the problem with mine..

agomes1971
Valued Contributor

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi,

When you are doing the data manipulation and moving around field names, sometimes you leave the original field among the others and create a duplicated one.  You may get this error message.

Kind regards

André Gomes

agomes1971
Valued Contributor

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi,

have you reached any conclusion?

Thanks

André Gomes

manasamale
New Contributor II

Re: ErrorSource: Microsoft OLE DB Service Components, ErrorMsg: Class not registered

Hi,

Andre Gomes

No, not yet..still trying..

Community Browser