Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2020: Join us May 11 - 14, 2020 in Phoenix, AZ. Register early and save $400. Learn More
Not applicable

Excel 2010 export - capping at 65K and should not

Excel 2010 is installed on a Windows Server 2010 R2 operating system. We are using QlikView 10.0 for 64bit.

The problem is that when one clicks on the "send to excel" icon at the top of a Qlikview pivot table report, the resulting excel output file is capping the data at 65536 records, when in fact there are many more records than that. My understanding is that Excel 2010 should allow 1,048,576 rows and 16,384 columns.

Please advise.

Thanks,

Stephanie Lind

Tags (1)
14 Replies
isaiah82
Contributor III

Excel 2010 export - capping at 65K and should not

Hi Stephanie > I believe the export format from QlikView is the 97 -2003 format (note the .xls extension) and hence the 65k limit. These must take forever to export! -Isaiah

Not applicable

Excel 2010 export - capping at 65K and should not

Thank you, Isaiah!!! That makes sense 🙂

Anywhere this may be documented, as I would like to send to my customer?

Stephanie

isaiah82
Contributor III

Excel 2010 export - capping at 65K and should not

Haha not to the best of my knowledge. This is pretty standard for apps to export in this format. One alternative may be to export out as a .CSV or similar (usually .csv is associated with Excel) and that may get around this (right-click on the chart header and click Export..or you could set up a button.)

I did check the APIGuide seeing if there was an option to export in the 2010 (ooxml) format but I don't believe that's the case. I would imagine it will be before long though..

-Isaiah

Highlighted
Not applicable

Re: Excel 2010 export - capping at 65K and should not

Hi Stephanie!

On the server, go to help, about QlikView.  Right click the icon in the lower left corner.  Navigate to RowLimitForCsvInsteadOfXls.  Change the value in the box and click set.  This will change the QlikView.ini file on the server and apply to all QlikView applications.

Cheers!

Larry Travnicek

RowLimit.png

Not applicable

Re: Excel 2010 export - capping at 65K and should not

Hi!

I did not find this window!

by Rebeca

Not applicable

Re: Excel 2010 export - capping at 65K and should not

Help, about, right click the logo

Not applicable

Re: Excel 2010 export - capping at 65K and should not

Thanks!

Not applicable

Re: Excel 2010 export - capping at 65K and should not

I'm trying but it's not work..any suggest so it can automatic create another sheet?

thanks

Re: Re: Excel 2010 export - capping at 65K and should not

Hi,

Hi Open QlikView Desktop on your server, Click on help menu and select about Qlikview Option.

Right click on the ikon show in picture.

Regards

ASHFAQ