Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

harshal27
Contributor

Execute command issue

Hello ,

I have been trying to Execute R code from 60 server and that R is installed on 140 server. With below Execute command in QVW.

EXECUTE "\\172.17.114.140\C$\Program Files\R\R-3.3.2\bin\x64\Rcmd.exe" BATCH "\\172.16.19.60\E$\sh\Sh_Changes_Portfolio\ClaimPA_IT-harshal_ErrorFree60.r"

It works fine when i manually reload qvw. but when i scheduled it on QMC its failing everytime with attached error.

Please help on this. I tried executing that command from command prompt it worked. but not working through QMC.Execute issue.PNG

7 Replies
Highlighted
MVP
MVP

Re: Execute command issue

Does the QMC service account have access to all the resources referenced by the command (including admin level to access the hidden C$ and E$ shares)?

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
Highlighted

Re: Execute command issue

Try below in Execute Command

wmic /node:YourServerIP /user:userName /password:passWord process call create 'cmd.exe /c call "YourBatPath"'

Modify as per your requirement.

Regards,

Prashant

Great dreamer's dreams never fulfilled, they are always transcended.
Highlighted
harshal27
Contributor

Re: Execute command issue

is below Execute statement correct as per your command-

EXECUTE wmic /node:\\172.17.114.140 /user:QLIKSENSE\SBILSUADM /password:password process call create 'cmd.exe /c call "E:\sh\Sh_Changes_Portfolio\Fraud R code.bat"';

Highlighted
harshal27
Contributor

Re: Execute command issue

I tried above command but its not running R code it just pops up cmd and closes.

Highlighted

Re: Execute command issue

Yes..

all command come inside double quote

EXECUTE " Command"

Regards,

Great dreamer's dreams never fulfilled, they are always transcended.
Highlighted
harshal27
Contributor

Re: Execute command issue

not working Prashant.

I tried above command but its not running R code it just pops up cmd and closes.

Highlighted
harshal27
Contributor

Re: Execute command issue

Yes service ID has full rights on that file and folders on other server. I am able to run manually but through QMC its failing.