Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Not applicable

Export macro does not work on Access Point?

Hi All,

we have a small application in which we created a button and applied macro to export the straight table data to an excel sheet. it all fine on desktop.

when i open the same document on access point, Export button does not work.

the path for the Excel destination after export is C:\Temp\test.xlsx. we are Using Qlikview 11.20 (IE plugin is installed by default???).

i have read lot of posts in the community and tried few things like provided system access to Macro, IE settings etc..

but nothing worked for me. our application link looks something like below:

http://<ServerName>/QvAJAXZfc/opendoc.htm?document=AP/QR008-LIMS.qvw&host=QVS@<ServerName>.

Can someone please suggest what should be done to achieve this task?

and also, when i give the path as C:\Temp\test.xlsx, does it get stored on server folder or local desktop folder?

I am new to qlikview.. so please help..

Thanks

Jyothi

Tags (1)
1 Reply
MVP & Luminary
MVP & Luminary

Re: Export macro does not work on Access Point?

There is no way that a macro that runs on a server will create an excel instance in code on the users local workstation. The server has no access to the users local workstation. Therefore that kind of macro will not work in documents deployed on the access point. Use something like NPrinting instead.


talk is cheap, supply exceeds demand