Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Announcing the newest addition to the Qlik Community, Qlik Gallery! Learn More
hansdevr
Contributor III

Field selection in Listbox (Trigger actions in sheet) does not work

I want to pre-select 'INTERFACE' in the Broncode field on opening of a certain sheet.

See attached picture. Any idea why it REFUSES to work for me?

 

Labels (1)
1 Solution

Accepted Solutions
gf
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

ah i see try
='IN*'
you forgot the "="
12 Replies
gf
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

Hello Hansdevr,

Try ='IN*' 

Should work.

Regards!

hansdevr
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

Hi gf,

Maybe it should, but it doesn't...

gf
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

Hello,

I tried it myself and it works fine.

Regards.

 

gf
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

Is Broncode your header or the real field name?

hansdevr
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

It definitely is the real name of the field. I also added the alternate state for this sheet.

gf
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

ah i see try
='IN*'
you forgot the "="
Highlighted
hansdevr
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

......no show.....

gf
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

Can you upload your project without data?

I will have a look at it.

hansdevr
Contributor III

Re: Field selection in Listbox (Trigger actions in sheet) does not work

Alas, rules in my firm are extremely strict on this.

I saved the action, saved the qvw, opened it again, did a reload, but still no show...

It's driving me up the walls, but at the same time it's no biggie.