Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

venkat_thota
New Contributor III

Format Issues with INPUTFIELD

Hi

I have a straight table with one column declared as Input field. Its working good as I tested. When I enter decimal numbers it takes them as %. For example, if I give 0.35 then it takes 35%, if I give 0.6 then it takes 60%. So far so good. 

For some users, the InputField column acting weird, its not taking decimals, its taking integers and doing the %. Lets take same examples, if user gives 0.35 it considers 0% rather than 35% and If user enters 35 then its taking 35%. Similarly if user enter 0.6 then it considers as 1% and user enter 60 then its considering 60%. 

Not sure why this is happening. Are these browser dependent? Browser settings play a role here or machine settings play a role here?

Labels (2)
12 Replies
MVP & Luminary
MVP & Luminary

Re: Format Issues with INPUTFIELD

It's just an idea that the region-settings from the OS or user in regard to the decimal-delimiter might be different. If the cause is not easy to find it might be an alternatively to adjust the logic to integers and to devide the appropriate results with 100.

- Marcus

venkat_thota
New Contributor III

Re: Format Issues with INPUTFIELD

Thank you Marcus for your reply. 

It shouldn't be browser dependent as it always connects to server. 

I was thinking about the alternative you mentioned, if I can't resolve I will go with this route. Only problem is user should know that its percentage field. If I ask them to enter integers they may be confuse.

MVP & Luminary
MVP & Luminary

Re: Format Issues with INPUTFIELD

I'm not sure that there is nothing within the communication between the browser and the server which might adjust the input-values like special-chars as " are usually replaced with " or they might be just removed. In your case this might happens if the user enters 0,35 instead of 0.35 - just ask the users how they enter the values exactly and what happens if they change the delimiter-char.

- Marcus

venkat_thota
New Contributor III

Re: Format Issues with INPUTFIELD

No, user entered in front of me and she entered correctly as 0.35.
MVP & Luminary
MVP & Luminary

Re: Format Issues with INPUTFIELD

Which browser (-release) is in use - maybe a change might help.

- Marcus

venkat_thota
New Contributor III

Re: Format Issues with INPUTFIELD

Browser is IE 11 and is same for all users.

MVP & Luminary
MVP & Luminary

Re: Format Issues with INPUTFIELD

IE Plugin or AJAX client?

venkat_thota
New Contributor III

Re: Format Issues with INPUTFIELD

Its AJAX client only.

Highlighted
MVP & Luminary
MVP & Luminary

Re: Format Issues with INPUTFIELD

What happens by the use of another browser like firefox or chrome? If it's worked it's an issue with the IE (settings) and if not it's a problem with the user/machine/network and it would be useful to check what happens on different ones (in both directions).

- Marcus