Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
IMPORTANT: Upcoming LEF Database Maintenance, Oct. 3rd - SEE DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

How to remove the first line of a "Table chart"

Hello everyone,

So I have this straight table built with the chart editor. When I load the data the first row of the table does not have any values on any cells, only a dash  ( - ) on the corresponding the expression.

The data I load to the table doesn't have any empty line.

How can I prevent this line to show?

Is there any option to hide it?

In attachment there is a image to help understand the issue.

Thank you for the help

Best regards!

1 Solution

Accepted Solutions
Highlighted
Not applicable

So I kinda solved the problem...

I wanted to remove that line because I want to export the table to an excel file and that line was also being exported.

I checked the option "Suppress Header row" on the Presentation tab and now when I export to the file, the empty line it is not shown. So for me this is OK and it works for what I want but the "No Totals" option do not work, the line is still there, but like I was saying when I export to excel it goes away.

Probably when the export is done the first line is removed because the line with the headers was also being removed the first time I exported.

Thank you for the help, and if there is any other things to try to help someone else I could do it.

Best regards!

View solution in original post

10 Replies
Highlighted
Master II
Master II

p00.pngYou need to "descheek" total buton

Highlighted
Specialist II
Specialist II

In the straight and pivot table,

first row is nothing but name of column, i don't thing so you can disable it.

If you don't want name of column then left null at lable text, but still it will appear as null.

-- Regards,

Vishal Waghole

Highlighted
Not applicable

Hi Vishal,

Yes, you are correct, the first line has the name of the columns, so technically what I want gone is the second line XD

The attached image show witch line I want to remove. The line on top of that is the one that has the names of the columns.

Regards

Highlighted
Not applicable

Hi Enrique,

Thank you for the answer but the "No totals" does not solve the problem

Regards

Highlighted
Luminary
Luminary

Hi,

Looks like you have total calculation enabled. If you want you can disable the total setting by selecting "No Totals" radio button on all the expressions. This only applicable to the expressions tab.

Cheers,

DV

www.QlikShare.com

Highlighted
MVP
MVP

For all the expressions check 'No Total' in total mode option.

Highlighted
Not applicable

Hi IVo,

If i am not wrong , ur first row is showing the total and that is missing .. just go to presentation tab and select TOTAL ON THE LAST ROW .

Thanks

Highlighted
Not applicable

So I kinda solved the problem...

I wanted to remove that line because I want to export the table to an excel file and that line was also being exported.

I checked the option "Suppress Header row" on the Presentation tab and now when I export to the file, the empty line it is not shown. So for me this is OK and it works for what I want but the "No Totals" option do not work, the line is still there, but like I was saying when I export to excel it goes away.

Probably when the export is done the first line is removed because the line with the headers was also being removed the first time I exported.

Thank you for the help, and if there is any other things to try to help someone else I could do it.

Best regards!

View solution in original post

Highlighted
Specialist II
Specialist II

Nice one... I don't know that property.

Learn something new from you Ivo Marques 

-- Thanks and Regards,

Vishal Waghole